hbase-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Sergey Bartunov <sbos....@gmail.com>
Subject Re: Hbase first run problem
Date Wed, 11 Feb 2009 13:37:44 GMT
Thank you. Now it works

2009/2/11 Ryan Rawson <ryanobjc@gmail.com>:
> Do:
> hadoop fs -rmr /hbase
>
> and try again.
>
> HBase will auto-create the /hbase dir on the first run.
>
> -ryan
>
> On Wed, Feb 11, 2009 at 1:50 AM, Sergey Bartunov <sbos.net@gmail.com> wrote:
>
>> Hi. I'm trying to make hbase (0.19) running on my ubuntu 8.10. Hadoop
>> (0.19) already works in single-node mode:
>>
>> <configuration>
>>  <property>
>>    <name>fs.default.name</name>
>>    <value>hdfs://localhost:9000</value>
>>  </property>
>>  <property>
>>    <name>mapred.job.tracker</name>
>>    <value>localhost:9001</value>
>>  </property>
>>  <property>
>>    <name>dfs.replication</name>
>>    <value>1</value>
>>  </property>
>> </configuration>
>>
>> I've formatted namenode and created /hbase directory, which is
>> specified in hbase-site.xml:
>>
>> <configuration>
>>  <property>
>>     <name>hbase.master</name>
>>     <value>localhost:60000</value>
>>     <description>The host and port that the HBase master runs
>> at</description>
>>   </property>
>>
>>   <property>
>>     <name>hbase.rootdir</name>
>>     <value>hdfs://localhost:9000/hbase</value>
>>     <description>location of HBase instance in dfs</description>
>>   </property>
>>
>> </configuration>
>>
>> When I try to hbase/bin/start-hbase.sh HMaster falls with warning:
>>
>> WARNING! File system needs to be upgraded. Run the
>> '${HBASE_HOME}/bin/hbase migrate' script.
>>
>> But I can't upgrade because file hbase.version doesn't exist and I
>> don't understand why I need to upgrade if I use the last version of
>> hadoop. Also I have no idea how to get hbase.version file.
>> What I have to do to make this work? Thanks in advance
>>
>> --
>> Rideamus!
>>
>



-- 
Rideamus!

Mime
View raw message