hbase-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Yair Even-Zohar" <ya...@revenuescience.com>
Subject RE: backup tables using ImportMR / ExportMR ( HBASE-974 )
Date Wed, 11 Feb 2009 12:59:23 GMT
Alas, I'm afraid the problem is in the ImporterMR

My cluster is loading data to Hbase from a different set of fuiles using
the TableReduce so I know it is not the cluster setup.
I also output the Hbase data to a text file (so I am guaranteed that the
data is inserted to the cluster)

There could be some miscommunication between my cluster setup and the
Importer. I don't know what is that miscommunication though.

Another small detail, the importer does not set the reducer class in the
JobConf... I tried doing that too, didn't help :-(

I think this is not a big deal because the reducer class is defined in
the initRecudetask but that's one more thing to keep in mind.

Thanks
-Yair

-----Original Message-----
From: Erik Holstad [mailto:erikholstad@gmail.com] 
Sent: Tuesday, February 10, 2009 11:04 PM
To: hbase-user@hadoop.apache.org
Subject: Re: backup tables using ImportMR / ExportMR ( HBASE-974 )

Hey Yair!

So you are saying that you don't think that the problem is in the
importer
but in your cluster
setup?

Thanks for finding all these small things, like with the @Override for
example.
I haven't used the code in a little while, but will get my hands dirty
tomorrow morning, so we
can figure this out and get it working for you, my test cluster is down
at
the moment but will
hopefully be up tomorrow :)

So, maybe you can some hang out on the IRC and we will try to get this
going
tomorrow?

Regards Erik

Mime
View raw message