hbase-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Jean-Adrien <a...@jeanjean.ch>
Subject Re: Regionserver fails to serve region
Date Thu, 23 Oct 2008 07:59:43 GMT

Hello again.


stack-3 wrote:
> 
> 
>  
> I could be wrong, but I don't see how.  You are running start-dfs.sh 
> over in HADOOP_HOME, not in HBASE_HOME.  Unless you somehow have 
> CLASSPATHs intermingled, datanode startup should not be picking up 
> content of HBASE_HOME/conf.
> 
> 

Yes, in fact that was my mistake: I haven't run finalizeUpgrade admin
command on Hadoop. Rollback files took a lot of space, maybe related. Anyway
all other hadoop settings are working.


stack-3 wrote:
> 
> 
> I owe you other answers/support.  In particular, I need to try running 
> dfs.datanode.socket.write.timeout = 0 to see if I get same problem as 
> you.  Let me know if anything else you'd have me try.
> 
> 

Finally I set the parameter increasing the limit of Xcievers (HADOOP-3633 /
HADOOP-3859) , because this limit is reached during HBase startup if I
disable channel timeout, as I wrote in my previous message

Then, using both properties:

<property>
  <name>dfs.datanode.socket.write.timeout</name>
  <value>0</value>
</property>

<property>
   <name>dfs.datanode.max.xcievers</name>
   <value>1023</value>
</property>

Hadoop is running with this configuration since 12h without any trace of
HADOOP-3831.
And therefore no "Premeture" in HBase. 

I don't know why in my configuration (probably the hardware is in cause)
this timeout happens without these parameters.

What could be done on the HBase side is maybe to try to reproduce such a
Hadoop failure. (e.g. giving low values to these Hadoop parameters) and to
see why the regions which suffer of one of these failure are not accessible
anymore before HBase is restarted.

Another thing I changed, and which is maybe linked to Hadoop behaviour: I
add the -server parameter to the jvm. Since the default ran client vm on a
1Gb RAM / single processor machine.


stack-3 wrote:
> 
> 
> Thanks for all the excellent diagnosis.
> St.Ack
> 
> 

You're welcome. It's a pleasure to contribute. Hope that helps.
Have a nice day.

-- J.-A.

-- 
View this message in context: http://www.nabble.com/Regionserver-fails-to-serve-region-tp20028553p20126171.html
Sent from the HBase User mailing list archive at Nabble.com.


Mime
View raw message