hbase-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Ding, Hui" <hui.d...@sap.com>
Subject RE: [LIKELY JUNK]Re: Problem writing data into table using M/R
Date Sat, 20 Sep 2008 00:20:57 GMT
Allen, thanks in advance! 

The bulk loading from flatfile to htable one.  
One thing I'm little confused is that the file path I supplied is to the
local path not the dfs, is this correct?
But when I tried to move the file to dfs and use the path there, it
gives me an error saying file cannot be found.

-----Original Message-----
From: Allen Day [mailto:allenday@gmail.com] 
Sent: Friday, September 19, 2008 5:15 PM
To: hbase-user@hadoop.apache.org
Subject: [LIKELY JUNK]Re: Problem writing data into table using M/R

Hi Ding,

Caveat emptor, I'm also new to HBase and did those examples as part of
learning the API.  But I'll try to help you.

Which example are you using the flatfile -> HTable, or HTable -> HTable?

-Allen

On Fri, Sep 19, 2008 at 5:07 PM, Ding, Hui <hui.ding@sap.com> wrote:
> Hi all,
>
> I'm having a problem writing data into hbase table using a m/r
program.
>
>
> I tried to run the sample code by Allen Day (the first one on the wiki
> page:http://wiki.apache.org/hadoop/Hbase/MapReduce)
> I put some logging statements in the mapper and see that there are the
> same number of mappers executed as there are cells to insert.  I don't
> see any error message etc,
> But then I don't see any data inserted after the program terminates!
>
> Meanwhile I was able to do the insertion and scan using the Client API
> and it works fine.
>
> Can someone please give me some hint where to look for problem?
>
> Thanks a lot!!!
>

Mime
View raw message