hbase-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Jim Kellerman <...@powerset.com>
Subject RE: [Announcement] HBase major release version to track Hadoop major releases.
Date Fri, 22 Aug 2008 15:40:53 GMT
My apologies. I take full responsibility. I have heard from many community members that the
old numbering scheme was confusing (I need which version of HBase to run with which version
of Hadoop? I tried HBase 1.x against Hadoop 0.17.x and it didn't work. ...)

It also makes it easier to assign issues to a particular HBase release if a particular HBase
feature depends on a feature in a particular Hadoop release.

Please accept my apologies for acting unilaterally, and not involving the community.

---
Jim Kellerman, Senior Engineer; Powerset (a Microsoft Company)

> -----Original Message-----
> From: saint.ack@gmail.com [mailto:saint.ack@gmail.com] On Behalf Of stack
> Sent: Thursday, August 21, 2008 9:14 PM
> To: hbase-user@hadoop.apache.org
> Subject: Re: [Announcement] HBase major release version to track Hadoop major
> releases.
>
> Yeah. My main beef is the lack of discussion up here on the lists.  IMO,
> there should have been a proposal and discussion over in hbase-dev first.
> Without it, the below has the ring of a decree and gives the mistaken
> impression that this is a project run by a dictatorship rather than by
> community.
>
> St.Ack
>
>
>
> On Thu, Aug 21, 2008 at 7:34 PM, Daniel Leffel
> <daniel.leffel@gmail.com>wrote:
>
> > I agree with the the version syncing, but agree more that there should
> > have been more discussion.
> >
> > On 8/21/08, stack <stack@duboce.net> wrote:
> > > -1
> > >
> > >  There was no discussion on the list ahead of the below fiat.
> > >
> > >  St.Ack
> > >
> > >
> > >
> > >  On Thu, Aug 21, 2008 at 3:37 PM, Jim Kellerman <jim@powerset.com>
> > wrote:
> > >
> > >  > Since HBase became a subproject of Hadoop, it started its own release
> > >  > numbering scheme. However, because a particular release of HBase
> > requires a
> > >  > specific release of Hadoop, HBase will change so that its major
> > releases
> > >  > correspond to the Hadoop major release that it depends on.
> > >  >
> > >  > For example, in the past:
> > >  > hbase-0.1.x required hadoop-0.16.x
> > >  > hbase-0.2.x requires hadoop-0.17.x
> > >  >
> > >  > The release that was to be named hbase-0.3.0 will be renamed to
> > >  > hbase-0.18.0 to reflect the fact that it requires a hadoop-0.18.x
> > release to
> > >  > run on.
> > >  >
> > >  > Similarly, hbase-0.4.0 will be renamed to hbase-0.19.0 to reflect that
> > it
> > >  > will require hadoop-0.19.x
> > >  >
> > >  > ---
> > >  > Jim Kellerman, Senior Engineer; Powerset (a Microsoft Company)
> > >  >
> > >  >
> > >
> >

Mime
View raw message