hbase-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Billy Pearson" <sa...@pearsonwholesale.com>
Subject TableNotFoundException ? on the end of my table name
Date Fri, 04 Jul 2008 08:35:19 GMT
I run a job on a old table webdata that I have had before I updated to 
latest trunk and everything runs fine then
I made a new table just like this one with the name webdata_test and this is 
what I get in the task logs:

2008-07-04 02:30:06,318 WARN org.apache.hadoop.mapred.TaskTracker: Error 
running child
org.apache.hadoop.hbase.TableNotFoundException: Table 'webdata_test?' was 
not found.
 at 
org.apache.hadoop.hbase.client.HConnectionManager$TableServers.locateRegionInMeta(HConnectionManager.java:534)
 at 
org.apache.hadoop.hbase.client.HConnectionManager$TableServers.locateRegion(HConnectionManager.java:470)
 at 
org.apache.hadoop.hbase.client.HConnectionManager$TableServers.locateRegion(HConnectionManager.java:430)
 at org.apache.hadoop.hbase.client.HTable.<init>(HTable.java:124)
 at org.apache.hadoop.hbase.client.HTable.<init>(HTable.java:97)
 at com.compspy.mapred.RecordImport$MapClass.getTable(RecordImport.java:50)
 at com.compspy.mapred.RecordImport$MapClass.map(RecordImport.java:76)
 at org.apache.hadoop.mapred.MapRunner.run(MapRunner.java:47)
 at org.apache.hadoop.mapred.MapTask.run(MapTask.java:219)
 at org.apache.hadoop.mapred.TaskTracker$Child.main(TaskTracker.java:2124)

It has a ? on the end of the name and I can not find out why I tryed this 
with several new tables and all turn out the same error above execpt the old 
table webdata

my job does this
HTable table = new HTable(c, new Text("webdata"));
no problem but any new table I make I get the above error like when I do 
this
HTable table = new HTable(c, new Text("webdata_test"));

I scaned meta with the shell and the name appears correctly there from what 
I can tell.
I have been createing the tables with the shell.

Any suggestions on where the ? is comming from? 



Mime
View raw message