hbase-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From stack <st...@duboce.net>
Subject Re: HRegionServer: error opening region
Date Thu, 24 Jul 2008 16:51:49 GMT
Renaud Delbru wrote:
> Hi Stack, Jean-Daniel,
>
> Yes, this is a production environment ;o). But, I was aware of the 
> potential problems that can cause the use of a nightly build. I moved 
> from 0.13 to 0.2 thinking that it will solve the stability problems we 
> encountered (which in fact solve some of them).

Tell us about the others.
>
> Ok, so if I understand, I just have to change the version number to 
> 0.1(in hbase.version), and do the normal upgrade procedure. I will try 
> it and keep you informed.
>

Yes.  Its a binary file unfortunately so it'll be a little awkward to it.

You may need to make the below change to your Migrate script:

Index: util/Migrate.java
===================================================================
--- util/Migrate.java   (revision 679456)
+++ util/Migrate.java   (working copy)
@@ -207,7 +207,7 @@
  
   private void migrateToV5() throws IOException {
     rewriteMetaHRegionInfo();
-    addHistorianFamilyToMeta();
+    // addHistorianFamilyToMeta();
     updateBloomFilters();
   }


If at v3, you already have the region historian in your instance.

But you could try without making the above change.  Looking at the code, 
its not completely dumb checking first if the historian is present and 
only adding it if its missing.

St.Ack


> Thanks for the advices.


Mime
View raw message