hbase-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Jean-Daniel Cryans" <jdcry...@gmail.com>
Subject Re: Retrying connect to server error
Date Mon, 21 Jul 2008 14:58:14 GMT
Arber,

When the Master starts, it checks on the filesystem for a file named
"hbase.version" in your HBase root folder. If the version of your HBase
distribution changed OR if the file is missing, it will throw the error you
see. I would advise confirming that the file is still there.

Also, the migrate script first tries to connect to the Master to make sure
it is offline. It retries a couple of times (the error you see) then proceed
to doing the migration.

Hope it helps,

J-D

On Mon, Jul 21, 2008 at 5:17 AM, Yabo-Arber Xu <arber.research@gmail.com>
wrote:

> Greetings,
>
> I am right now using hbase in our project in "stand-alone" mode. It worked
> well until today I found the following message in the log:
>
> 2008-07-21 01:16:38,564 FATAL org.apache.hadoop.hbase.HMaster: Not starting
> HMaster because: org.apache.hadoop.hbase.FileSystemVersionException: File
> system needs to be upgraded. Run the '${HBASE_HOME}/bin/hbase migrate'
> script.
>
> I actually did not do any version change recently. But, anyway, i followed
> the message and tried to do "hbase migrate", but it keeps showing me the
> following error:
>
> 08/07/21 02:11:51 INFO ipc.Client: Retrying connect to server: localhost/
> 127.0.0.1:60000. Already tried 1 time(s).
>
> The same error occurs when i try to do any query through hbase shell. This
> is just wierd....I did not touch any part of the hbase, and the error just
> sundenly came out. Any ideas why?
>
> Thanks for your help! The whole project is just stuck here by this error.
>
> Arber
>
>
> --
> Yabo-Arber Xu <yxu@cs.sfu.ca>
> Web: http://www.cs.sfu.ca/~yxu/personal/<http://www.cs.sfu.ca/%7Eyxu/personal/>
> <http://www.cs.sfu.ca/%7Eyxu/personal/>
>

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message