hbase-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From stack <st...@duboce.net>
Subject Re: HBase Master only listening to Local Connections on 60000?
Date Thu, 01 May 2008 17:13:55 GMT
Daniel:

The line out of RpcMetrics reporting port for hostname looks like a 
little bug we should fix up in hadoop core (I took a quick look; looks 
like the right args are being passed -- problem must be further up the 
stack or perhaps your hadoop is older?).

Regards the next line reporting localhost, thats odd.  Is your 
networking setup properly?  What does the host report for IP when you 
query using the hostname you've inserted as the value for hbase.master?  
What if you use IP instead?

Here is what my logs looks like:

2008-05-01 04:15:34,234 INFO org.apache.hadoop.ipc.metrics.RpcMetrics: 
Initializing RPC Metrics with hostName=60000, port=60000
2008-05-01 04:15:34,361 INFO org.apache.hadoop.hbase.HMaster: HMaster 
initialized on XXX.XXX.44.139:60000

Here is my hbase.master:

aa0-XXX-XXX.at.our.domain:60000

St.Ack

P.S. And on offlining of tables, we're still working on it..... should 
have a candidate up in the next day or so w/ a fix included.


Daniel Leffel wrote:
> Actually, I did find something curious in the master log with debug turned
> on:
>
> 2008-05-01 11:05:56,407 INFO org.apache.hadoop.ipc.metrics.RpcMetrics:
> Initializing RPC Metrics with hostName=60000, port=60000
> 2008-05-01 11:05:56,482 INFO org.apache.hadoop.hbase.HMaster: HMaster
> initialized on 127.0.0.1:60000
>
> hostname 60000? but then the next line shows localhost?
>
> On Thu, May 1, 2008 at 9:32 AM, Daniel Leffel <daniel.leffel@gmail.com>
> wrote:
>
>   
>> Not sure what's going on with this and thought I'd ask. I can't find any
>> rationale for this on the wiki or in the logs.
>>
>> I've begun to set up our production environment which is a multi-node
>> setup. (To-date our development environment was a single node in
>> psudeo-distributed mode).
>>
>> The HBase master is listening on port 60000 only for connections that are
>> local and is refusing remote connections. All the other services on the box
>> (60010,600020 and 600030) listen both locally and remotely. There's no
>> firewall on the box.
>>
>> In the hbase-site.xml, I've specificed hbase.master to be [hostname]:60000
>>
>> Any ideas?
>>
>>     
>
>   


Mime
View raw message