hbase-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Peeyush Bishnoi <peeyu...@yahoo-inc.com>
Subject Re: HBase Startup Errors
Date Thu, 21 Feb 2008 06:37:37 GMT
Hi Chris ,

Can you check the hbase related logs in $HADOOP_HOME/logs directory for
more information. 

---
Peeyush Bishnoi

On Thu, 2008-02-21 at 01:03 -0500, Chris Richard wrote:

> Follow up to this. I removed the http:// from the hbase.master setting and
> hbase seems to start successfully. Unfortunately I get the following error
> on the web UI and upon running any query in the shell:
> 
> org.apache.hadoop.hbase.NoServerForRegionException: Timed out trying to
> locate root region
> 
> On Thu, Feb 21, 2008 at 12:40 AM, Chris Richard <chris.richard@gmail.com>
> wrote:
> 
> > Hi All,
> >
> > I've got hdfs (single node) running successfully, as far as I can tell.
> > Unfortunately hbase is exceptioning on startup - probably a config issue but
> > I can't figure out what.
> >
> > I'm using the latest hadoop from the trunk, likewise for hbase, and I'm
> > running on Win2k3 with Cygwin. Following are my hadoop-site.xml and
> > hbase-site.xml:
> >
> > hadoop
> > <configuration>
> > <property>
> >   <name>hadoop.tmp.dir</name>
> >   <value>/cygdrive/d/datarepublik/tmp/hadoop-${user.name}</value>
> > </property>
> > <property>
> >   <name>fs.default.name</name>
> >   <value>localhost:9001</value>
> > </property>
> > <property>
> >   <name>mapred.job.tracker</name>
> >   <value>localhost:9002</value>
> > </property>
> > <property>
> >   <name>dfs.replication</name>
> >   <value>1</value>
> > </property>
> > <property>
> >   <name>mapred.child.java.opts</name>
> >   <value>-Xmx512m</value>
> > </property>
> > </configuration>
> >
> > hbase
> >  <configuration>
> >    <property>
> >      <name>hbase.master</name>
> >      <value>http://localhost:60000</value>
> >      <description>The host and port that the HBase master runs
> > at</description>
> >    </property>
> >    <property>
> >      <name>hbase.rootdir</name>
> >      <value>hdfs://localhost:9001/hbase</value>
> >      <description>The directory shared by region servers</description>
> >    </property>
> >  </configuration>
> >
> > The exception I get is:
> >
> > ...
> > 2008-02-21 00:33:09,906 WARN org.apache.hadoop.util.NativeCodeLoader:
> > Unable to load native-hadoop library for your platform... using builtin-java
> > classes where applicable
> > 2008-02-21 00:33:10,000 INFO org.apache.hadoop.hbase.HRegion: closed
> > -ROOT-,,0
> > 2008-02-21 00:33:10,453 INFO org.apache.hadoop.hbase.HRegion: closed
> > .META.,,1
> > 2008-02-21 00:33:10,500 ERROR org.apache.hadoop.hbase.master.HMaster: Can
> > not start master
> > java.lang.reflect.InvocationTargetException
> >     at sun.reflect.NativeConstructorAccessorImpl.newInstance0(Native
> > Method)
> >     at sun.reflect.NativeConstructorAccessorImpl.newInstance(
> > NativeConstructorAccessorImpl.java:39)
> >     at sun.reflect.DelegatingConstructorAccessorImpl.newInstance(
> > DelegatingConstructorAccessorImpl.java:27)
> >     at java.lang.reflect.Constructor.newInstance(Constructor.java:494)
> >     at org.apache.hadoop.hbase.master.HMaster.doMain(HMaster.java:1540)
> >     at org.apache.hadoop.hbase.master.HMaster.main(HMaster.java:1574)
> > Caused by: java.lang.NullPointerException
> >     at org.apache.hadoop.hbase.HServerAddress.getBindAddress(
> > HServerAddress.java:94)
> >     at org.apache.hadoop.hbase.master.HMaster.<init>(HMaster.java:319)
> >     at org.apache.hadoop.hbase.master.HMaster.<init>(HMaster.java:242)
> >     ... 6 more
> >
> > I'm a bit of a Java n00b so I couldn't figure out how to attach to the
> > process in time to debug the error. Any help would be greatly appreciated.
> > Thanks.
> >
> > Chris Richard
> >

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message