hbase-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "stack (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (HBASE-21513) [rm] make_rc.sh doesn't work on mac os x
Date Mon, 26 Nov 2018 18:41:00 GMT

    [ https://issues.apache.org/jira/browse/HBASE-21513?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=16699427#comment-16699427
] 

stack commented on HBASE-21513:
-------------------------------

Let me try your suggestion next time [~Apache9]

> [rm] make_rc.sh doesn't work on mac os x
> ----------------------------------------
>
>                 Key: HBASE-21513
>                 URL: https://issues.apache.org/jira/browse/HBASE-21513
>             Project: HBase
>          Issue Type: Bug
>          Components: build
>            Reporter: stack
>            Priority: Major
>
> Trying to build an RC on a mac, it fails always for me with:
> {code}
> [ERROR] Failed to execute goal org.apache.maven.plugins:maven-assembly-plugin:2.6:single
(default-cli) on project hbase-assembly: Failed to create assembly: Error adding file 'org.apache.hbase:hbase-common:jar:tests:2.0.3'
to archive: /Users/stack/checkouts/hbase.git/hbase-common/target/test-classes isn't a file.
-> [Help 1]
> [ERROR]
> {code}
> This is the second build that tries to assemble the tgz inside in make_rc.sh.
> If I leave out 'site' target, it works. I tried an earlier version that current head
of branch-2.0 and it had same issue.
> [~busbey] had a nice suggestion changing the -DskipTests to -Dtest=NO_SUCH_TEST ... but
that didn't work for me.
> I went and got a linux vm and it just worked.



--
This message was sent by Atlassian JIRA
(v7.6.3#76005)

Mime
View raw message