hbase-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Hudson (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (HBASE-20189) Typo in Required Java Version error message while building HBase.
Date Wed, 28 Mar 2018 02:51:03 GMT

    [ https://issues.apache.org/jira/browse/HBASE-20189?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=16416660#comment-16416660
] 

Hudson commented on HBASE-20189:
--------------------------------

Results for branch HBASE-19064
	[build #77 on builds.a.o|https://builds.apache.org/job/HBase%20Nightly/job/HBASE-19064/77/]:
(x) *{color:red}-1 overall{color}*
----
details (if available):

(x) {color:red}-1 general checks{color}
-- For more information [see general report|https://builds.apache.org/job/HBase%20Nightly/job/HBASE-19064/77//General_Nightly_Build_Report/]




(x) {color:red}-1 jdk8 hadoop2 checks{color}
-- For more information [see jdk8 (hadoop2) report|https://builds.apache.org/job/HBase%20Nightly/job/HBASE-19064/77//JDK8_Nightly_Build_Report_(Hadoop2)/]


(x) {color:red}-1 jdk8 hadoop3 checks{color}
-- For more information [see jdk8 (hadoop3) report|https://builds.apache.org/job/HBase%20Nightly/job/HBASE-19064/77//JDK8_Nightly_Build_Report_(Hadoop3)/]


(/) {color:green}+1 source release artifact{color}
-- See build output for details.


> Typo in Required Java Version error message while building HBase.
> -----------------------------------------------------------------
>
>                 Key: HBASE-20189
>                 URL: https://issues.apache.org/jira/browse/HBASE-20189
>             Project: HBase
>          Issue Type: Bug
>          Components: build
>            Reporter: Sakthi
>            Assignee: Sakthi
>            Priority: Trivial
>              Labels: beginner, beginners
>             Fix For: 2.1.0, 1.3.2, 1.2.7, 1.4.3, 2.0.0
>
>         Attachments: hbase-20189.master.001.patch
>
>
> Change 'requirs' to 'requires'. See below:
> {code:java}
> $ mvn clean install -DskipTests
> ...
> [WARNING] Rule 2: org.apache.maven.plugins.enforcer.RequireJavaVersion failed with message:
> Java is out of date.
>   HBase requirs at least version 1.8 of the JDK to properly build from source.
>   You appear to be using an older version. You can use either "mvn -version" or
>   "mvn enforcer:display-info" to verify what version is active.
>   See the reference guide on building for more information: http://hbase.apache.org/book.html#build
> {code}



--
This message was sent by Atlassian JIRA
(v7.6.3#76005)

Mime
View raw message