hbase-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Andrew Purtell (JIRA)" <j...@apache.org>
Subject [jira] [Created] (HBASE-20089) make_rc.sh should name SHA-512 checksum files with the extension .sha512
Date Mon, 26 Feb 2018 21:00:01 GMT
Andrew Purtell created HBASE-20089:
--------------------------------------

             Summary: make_rc.sh should name SHA-512 checksum files with the extension .sha512
                 Key: HBASE-20089
                 URL: https://issues.apache.org/jira/browse/HBASE-20089
             Project: HBase
          Issue Type: Task
            Reporter: Andrew Purtell


>From [~elserj]
{quote}
we need to update the checksum naming convention for SHA*. Per [1], .sha filenames should
only contain SHA1, and .sha512 file names should be used for SHA512 xsum. I believe this means
we just need to modify make_rc.sh to put the xsum into .sha512 instead of .sha. We do not
need to distribute SHA1 xsums and, afaik, there is little cryptographic value to this.

[1] http://www.apache.org/dev/release-distribution.html#sigs-and-sums
{quote}



--
This message was sent by Atlassian JIRA
(v7.6.3#76005)

Mime
View raw message