hbase-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Duo Zhang (JIRA)" <j...@apache.org>
Subject [jira] [Updated] (HBASE-19795) Move the tests which only need zookeeper in TestZooKeeper to hbase-zookeeper module
Date Sun, 14 Jan 2018 09:07:00 GMT

     [ https://issues.apache.org/jira/browse/HBASE-19795?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

Duo Zhang updated HBASE-19795:
------------------------------
    Attachment: HBASE-19795.patch

Move the isClientReadable method from ZKWatcher to ZNodePaths and move the old TestZKWatcher
test from hbase-zookeeper to hbase-client and rename it to TestZNodePaths.

Rename the old TestZKUtil to TestZKUtilNoServer, and introduce a new TestZKUtil to place the
methods which are moved from TestZooKeeper.

> Move the tests which only need zookeeper in TestZooKeeper to hbase-zookeeper module
> -----------------------------------------------------------------------------------
>
>                 Key: HBASE-19795
>                 URL: https://issues.apache.org/jira/browse/HBASE-19795
>             Project: HBase
>          Issue Type: Sub-task
>            Reporter: Duo Zhang
>             Fix For: 2.0.0-beta-2
>
>         Attachments: HBASE-19795.patch
>
>
> Make the flakey test smaller.



--
This message was sent by Atlassian JIRA
(v6.4.14#64029)

Mime
View raw message