hbase-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Ted Yu (JIRA)" <j...@apache.org>
Subject [jira] [Updated] (HBASE-19771) restore_snapshot shell command gives wrong namespace if the namespace doesn't exist
Date Fri, 12 Jan 2018 15:39:00 GMT

     [ https://issues.apache.org/jira/browse/HBASE-19771?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

Ted Yu updated HBASE-19771:
---------------------------
       Resolution: Fixed
     Hadoop Flags: Reviewed
    Fix Version/s: 2.0.0-beta-2
           Status: Resolved  (was: Patch Available)

Thanks for the patch, Janos.

> restore_snapshot shell command gives wrong namespace if the namespace doesn't exist
> -----------------------------------------------------------------------------------
>
>                 Key: HBASE-19771
>                 URL: https://issues.apache.org/jira/browse/HBASE-19771
>             Project: HBase
>          Issue Type: Bug
>    Affects Versions: 2.0.0-beta-1
>            Reporter: Ted Yu
>            Assignee: Janos Gub
>            Priority: Minor
>             Fix For: 2.0.0-beta-2
>
>         Attachments: HBASE-19771.master.001.patch
>
>
> For the following snapshot:
> {code}
>  snapshot_table_tav6mrq397                                  NS592088:table_tav6mrq397
(2018-01-10 16:20:39 UTC)
> {code}
> namespace NS592088 is dropped.
> restore_snapshot on the snapshot gave the following :
> {code}
> hbase(main):003:0> restore_snapshot 'snapshot_table_tav6mrq397'
> ERROR: Unknown namespace snapshot_table_tav6mrq397!
> {code}
> The namespace in the message was incorrect.



--
This message was sent by Atlassian JIRA
(v6.4.14#64029)

Mime
View raw message