hbase-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "stack (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (HBASE-19678) HBase Admin security capabilities should be represented as a Set
Date Wed, 17 Jan 2018 19:37:00 GMT

    [ https://issues.apache.org/jira/browse/HBASE-19678?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=16329286#comment-16329286

stack commented on HBASE-19678:

>From HBASE-19679: "OK, so I made a mistake here. I posted the same patch under two different
tickets. The ticket HBASE-19678 should be re-opened as that ticket points out a larger structural
issue. This ticket should be closed because of the patch that was submitted as part of HBASE-19678 is
a duplicate of the one provided here and was already applied."

> HBase Admin security capabilities should be represented as a Set
> ----------------------------------------------------------------
>                 Key: HBASE-19678
>                 URL: https://issues.apache.org/jira/browse/HBASE-19678
>             Project: HBase
>          Issue Type: Improvement
>          Components: hbase
>    Affects Versions: 3.0.0
>            Reporter: BELUGA BEHR
>            Assignee: BELUGA BEHR
>            Priority: Minor
>             Fix For: 2.0.0-beta-2
> {code:title=org.apache.hadoop.hbase.client.Admin}
>   /**
>    * Return the set of supported security capabilities.
>    * @throws IOException
>    * @throws UnsupportedOperationException
>    */
>   List<SecurityCapability> getSecurityCapabilities() throws IOException;
> {code}
> The comment says a "set" but it returns a List.  A Set would be the most appropriate
data structure here, an immutable one perhaps, because the code that interacts with it looks
up information using the _contains_ method which would be served well by a Set.  Please change
this interface to return a Set.

This message was sent by Atlassian JIRA

View raw message