hbase-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Andrew Purtell (JIRA)" <j...@apache.org>
Subject [jira] [Updated] (HBASE-19393) HTTP 413 FULL head while accessing HBase UI using SSL.
Date Fri, 01 Dec 2017 01:09:00 GMT

     [ https://issues.apache.org/jira/browse/HBASE-19393?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

Andrew Purtell updated HBASE-19393:
-----------------------------------
       Resolution: Fixed
     Hadoop Flags: Reviewed
    Fix Version/s: 1.1.13
                   1.2.7
                   1.3.2
           Status: Resolved  (was: Patch Available)

Pushed to branch-1.1, branch-1.2, branch-1.3, branch-1.4, and branch-1. 

> HTTP 413 FULL head while accessing HBase UI using SSL. 
> -------------------------------------------------------
>
>                 Key: HBASE-19393
>                 URL: https://issues.apache.org/jira/browse/HBASE-19393
>             Project: HBase
>          Issue Type: Bug
>          Components: UI
>    Affects Versions: 1.4.0
>         Environment: SSL enabled for UI/REST. 
>            Reporter: Sergey Soldatov
>            Assignee: Sergey Soldatov
>             Fix For: 1.4.0, 1.3.2, 1.2.7, 1.1.13
>
>         Attachments: HBASE-19393-branch-1.patch, HBASE-19393.patch
>
>
> For REST/UI we are using 64Kb header buffer size instead of the jetty default 6kb (?).
But it comes that we set it only for _http_ protocol, but not for _https_. So if SSL is enabled
it's quite easy to get HTTP 413 error. Not relevant to branch-2 nor master because it's fixed
by HBASE-12894



--
This message was sent by Atlassian JIRA
(v6.4.14#64029)

Mime
View raw message