hbase-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "stack (JIRA)" <j...@apache.org>
Subject [jira] [Updated] (HBASE-19349) Introduce wrong version depencency of servlet-api jar
Date Thu, 07 Dec 2017 23:24:00 GMT

     [ https://issues.apache.org/jira/browse/HBASE-19349?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

stack updated HBASE-19349:
--------------------------
    Assignee: Guanghao Zhang
      Status: Patch Available  (was: Open)

Assigning [~zghaobac] because he did the hard work figuring which jar was the problem.

> Introduce wrong version depencency of servlet-api jar
> -----------------------------------------------------
>
>                 Key: HBASE-19349
>                 URL: https://issues.apache.org/jira/browse/HBASE-19349
>             Project: HBase
>          Issue Type: Bug
>    Affects Versions: 2.0.0-beta-1
>            Reporter: Guanghao Zhang
>            Assignee: Guanghao Zhang
>            Priority: Critical
>             Fix For: 2.0.0-beta-1
>
>         Attachments: 0002-HBASE-19349-Introduce-wrong-version-depencency-of-se.patch,
19349.txt
>
>
> Build a tarball.
> {code}
> mvn -DskipTests clean install && mvn -DskipTests package assembly:single
> tar zxvf hbase-2.0.0-beta-1-SNAPSHOT-bin.tar.gz
> {code}
> Then I found there is a servlet-api-2.5.jar in the lib directory. The right depencency
should be javax.servlet-api-3.1.0.jar.
> Start a distributed cluster with this tarball. And got exception when access Master/RS
info jsp.
> {code}
> 2017-11-27,10:02:05,066 WARN org.eclipse.jetty.server.HttpChannel: /
> java.lang.NoSuchMethodError: javax.servlet.http.HttpServletRequest.isAsyncSupported()Z
>         at org.eclipse.jetty.server.ResourceService.sendData(ResourceService.java:689)
>         at org.eclipse.jetty.server.ResourceService.doGet(ResourceService.java:294)
>         at org.eclipse.jetty.servlet.DefaultServlet.doGet(DefaultServlet.java:458)
>         at javax.servlet.http.HttpServlet.service(HttpServlet.java:707)
>         at javax.servlet.http.HttpServlet.service(HttpServlet.java:820)
>         at org.eclipse.jetty.servlet.ServletHolder.handle(ServletHolder.java:841)
>         at org.eclipse.jetty.servlet.ServletHandler$CachedChain.doFilter(ServletHandler.java:1650)
>         at org.apache.hadoop.hbase.http.lib.StaticUserWebFilter$StaticUserFilter.doFilter(StaticUserWebFilter.java:113)
>         at org.eclipse.jetty.servlet.ServletHandler$CachedChain.doFilter(ServletHandler.java:1637)
>         at org.apache.hadoop.hbase.http.ClickjackingPreventionFilter.doFilter(ClickjackingPreventionFilter.java:48)
>         at org.eclipse.jetty.servlet.ServletHandler$CachedChain.doFilter(ServletHandler.java:1637)
>         at org.apache.hadoop.hbase.http.HttpServer$QuotingInputFilter.doFilter(HttpServer.java:1374)
>         at org.eclipse.jetty.servlet.ServletHandler$CachedChain.doFilter(ServletHandler.java:1637)
>         at org.apache.hadoop.hbase.http.NoCacheFilter.doFilter(NoCacheFilter.java:49)
>         at org.eclipse.jetty.servlet.ServletHandler$CachedChain.doFilter(ServletHandler.java:1637)
>         at org.apache.hadoop.hbase.http.NoCacheFilter.doFilter(NoCacheFilter.java:49)
>         at org.eclipse.jetty.servlet.ServletHandler$CachedChain.doFilter(ServletHandler.java:1637)
>         at org.eclipse.jetty.servlet.ServletHandler.doHandle(ServletHandler.java:533)
> {code}
> Try mvn depencency:tree but didn't find why servlet-api-2.5.jar was introduced.
> I download hbase-2.0.0-alpha4-bin.tar.gz and didn't find servlet-api-2.5.jar. And build
a tar from hbase-2.0.0-alpha4-src.tar.gz and didn't find servlet-api-2.5.jar, too. So this
may be introduced by recently commits. And should fix this when release 2.0.0-beta1.



--
This message was sent by Atlassian JIRA
(v6.4.14#64029)

Mime
View raw message