hbase-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "ramkrishna.s.vasudevan (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (HBASE-19112) Suspect methods on Cell to be deprecated
Date Thu, 14 Dec 2017 07:31:00 GMT

    [ https://issues.apache.org/jira/browse/HBASE-19112?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=16290462#comment-16290462

ramkrishna.s.vasudevan commented on HBASE-19112:

Based on a comment in RB from Anoop.
The current change in the patch is that
Cell will have getType that returns the publicly exposed DataType. It will only have the puts
and deletes types and will not expose the Min/Max types.
But ExtendedCell will have getTypeByte() also along with getType (since ExtendedCell implements
Cell). getTypeByte will return the min/max types also. So is it ok to have both getTypeByte
and getType in ExtendedCell? 
IMHO it is fine because for internal usage we need all the fake cell types also and going
forward the server will be working purely with ExtendedCells only. 

> Suspect methods on Cell to be deprecated
> ----------------------------------------
>                 Key: HBASE-19112
>                 URL: https://issues.apache.org/jira/browse/HBASE-19112
>             Project: HBase
>          Issue Type: Bug
>          Components: Client
>            Reporter: Josh Elser
>            Assignee: ramkrishna.s.vasudevan
>            Priority: Blocker
>             Fix For: 2.0.0-beta-1
>         Attachments: HBASE-19112_branch-2.patch, HBASE-19112_branch-2_1.patch, HBASE-19112_master.patch,
HBASE-19112_master_1.patch, HBASE-19112_master_1.patch
> [~chia7712] suggested on the [mailing list|https://lists.apache.org/thread.html/e6de9af26d9b888a358ba48bf74655ccd893573087c032c0fcf01585@%3Cdev.hbase.apache.org%3E]
that we have some methods on Cell which should be deprecated for removal:
> * {{#getType()}}
> * {{#getTimestamp()}}
> * {{#getTag()}}
> * {{#getSequenceId()}}
> Let's make a pass over these (and maybe the rest) to make sure that there aren't others
which are either implementation details or methods returning now-private-marked classes.

This message was sent by Atlassian JIRA

View raw message