hbase-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Appy (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (HBASE-19255) PerformanceEvaluation class not found when run PE test
Date Tue, 14 Nov 2017 20:44:00 GMT

    [ https://issues.apache.org/jira/browse/HBASE-19255?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=16252148#comment-16252148
] 

Appy commented on HBASE-19255:
------------------------------

I think we do, for providing HBaseTestingUtility.

> PerformanceEvaluation class not found when run PE test
> ------------------------------------------------------
>
>                 Key: HBASE-19255
>                 URL: https://issues.apache.org/jira/browse/HBASE-19255
>             Project: HBase
>          Issue Type: Bug
>    Affects Versions: 3.0.0, 2.0.0-beta-1
>            Reporter: Guanghao Zhang
>            Assignee: Guanghao Zhang
>             Fix For: 3.0.0, 2.0.0-beta-1
>
>         Attachments: HBASE-19255.master.001.patch
>
>
> {code}
> mvn clean package install -DskipTests
> ./hbase org.apache.hadoop.hbase.PerformanceEvaluation --rows=10000 --nomapred randomWrite
1
> {code}
> PerformanceEvaluation is in hbase-mapreduce module's test jar. After HBASE-18640, we
move mapreduce out of hbase-server into separate hbase-mapreduce module. But didn't add the
hbase-mapreduce test jar to hbase-assembly pom.xml. So it didn't add to the default classpath.
Then the PerformanceEvaluation can't found.



--
This message was sent by Atlassian JIRA
(v6.4.14#64029)

Mime
View raw message