hbase-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Hudson (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (HBASE-19102) TestZooKeeperMainServer fails with KeeperException$ConnectionLossException
Date Tue, 07 Nov 2017 04:45:00 GMT

    [ https://issues.apache.org/jira/browse/HBASE-19102?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=16241474#comment-16241474
] 

Hudson commented on HBASE-19102:
--------------------------------

FAILURE: Integrated in Jenkins build HBase-1.2-JDK8 #265 (See [https://builds.apache.org/job/HBase-1.2-JDK8/265/])
HBASE-19102 TestZooKeeperMainServer fails with KeeperException (stack: rev 498bcba095b7f108498d025e862a3bb741416b1d)
* (edit) hbase-server/src/main/java/org/apache/hadoop/hbase/zookeeper/ZooKeeperMainServer.java


> TestZooKeeperMainServer fails with KeeperException$ConnectionLossException
> --------------------------------------------------------------------------
>
>                 Key: HBASE-19102
>                 URL: https://issues.apache.org/jira/browse/HBASE-19102
>             Project: HBase
>          Issue Type: Bug
>            Reporter: stack
>            Assignee: stack
>             Fix For: 1.4.0, 1.3.2, 1.2.7, 2.0.0-beta-1
>
>         Attachments: HBASE-19102.master.001.patch, HBASE-19102.master.002.patch, HBASE-19102.master.002.patch
>
>
> I'm trying to run test suite on a local machine. I never get to the second part because
I fail on below test with below exception near every time (and an ipv6 test... will do that
next).  
> 1 -------------------------------------------------------------------------------
>   2 Test set: org.apache.hadoop.hbase.zookeeper.TestZooKeeperMainServer
>   3 -------------------------------------------------------------------------------
>   4 Tests run: 2, Failures: 0, Errors: 1, Skipped: 0, Time elapsed: 16.161 s <<<
FAILURE! - in org.apache.hadoop.hbase.zookeeper.TestZooKeeperMainServer
>   5 testCommandLineWorks(org.apache.hadoop.hbase.zookeeper.TestZooKeeperMainServer) 
Time elapsed: 15.848 s  <<< ERROR!
>   6 org.apache.zookeeper.KeeperException$ConnectionLossException: KeeperErrorCode = ConnectionLoss
for /testCommandLineWorks
>   7   at org.apache.hadoop.hbase.zookeeper.TestZooKeeperMainServer.testCommandLineWorks(TestZooKeeperMainServer.java:81)
> Looks like running the command before we are connected causes the above -- we pause 15
seconds and then throw the above.   If I wait until connected before proceding, stuff seems
to work reliably. I don't have access to the watcher on connections since we override the
zk main class... so this seems only avenue available at mo (This zk main thing is all a hack
around zk main because it had bugs ... but I think we have to keep the hack because folks
use different versions of zk. My $workplace defaults to something that is years old, 3.4.5
for instance).



--
This message was sent by Atlassian JIRA
(v6.4.14#64029)

Mime
View raw message