hbase-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Andrew Purtell (JIRA)" <j...@apache.org>
Subject [jira] [Updated] (HBASE-19098) Python based compatiblity checker fails if git repo does not have a remote named 'origin'
Date Thu, 09 Nov 2017 01:50:01 GMT

     [ https://issues.apache.org/jira/browse/HBASE-19098?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

Andrew Purtell updated HBASE-19098:
-----------------------------------
    Fix Version/s:     (was: 1.5.0)
                       (was: 1.4.0)

> Python based compatiblity checker fails if git repo does not have a remote named 'origin'
> -----------------------------------------------------------------------------------------
>
>                 Key: HBASE-19098
>                 URL: https://issues.apache.org/jira/browse/HBASE-19098
>             Project: HBase
>          Issue Type: Bug
>          Components: tooling
>            Reporter: Andrew Purtell
>            Assignee: Sean Busbey
>            Priority: Critical
>             Fix For: 3.0.0, 1.3.2, 1.2.7, 2.0.0-alpha-4
>
>         Attachments: HBASE-19098.0.patch
>
>
> The new Python based compatibility checker will fail if the local git repo does not have
a remote named "origin". I develop with multiple upstream repos and rename them according
to a custom convention. If the requirement that an upstream named "origin" must be present
could be removed, that would be good, or otherwise this should be documented next to the example
usage in the python source. 



--
This message was sent by Atlassian JIRA
(v6.4.14#64029)

Mime
View raw message