hbase-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Umesh Agashe (JIRA)" <j...@apache.org>
Subject [jira] [Updated] (HBASE-18961) doMiniBatchMutate() is big, split it into smaller methods
Date Fri, 03 Nov 2017 00:00:02 GMT

     [ https://issues.apache.org/jira/browse/HBASE-18961?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

Umesh Agashe updated HBASE-18961:
---------------------------------
    Release Note: HRegion.batchMutate()/ doMiniBatchMutate() is refactored with aim to unify
batchMutate() and mutateRows() code paths later. batchMutate() currently handles 2 types of
batches: MutationBatchOperations and ReplayBatchOperations. Common base class BatchOperations
is augmented with common methods which are overridden in derived classes as needed. doMiniBatchMutate()
is implemented using common methods in base class BatchOperations.  (was: HRegion.batchMutate()/
doMiniBatchMutate() is refactored with aim to unify batchMutate() and mutateRows() code paths.
batchMutate() currently handles 2 types of batches MutationBatch and ReplayBatch. Common base
class BatchOperations is augmented with common methods which are overridden in derived classes.
doMiniBatchMutate() is implemented using common methods in base class BatchOperations.)

> doMiniBatchMutate() is big, split it into smaller methods
> ---------------------------------------------------------
>
>                 Key: HBASE-18961
>                 URL: https://issues.apache.org/jira/browse/HBASE-18961
>             Project: HBase
>          Issue Type: Sub-task
>          Components: regionserver
>    Affects Versions: 2.0.0-alpha-3
>            Reporter: Umesh Agashe
>            Assignee: Umesh Agashe
>            Priority: Major
>             Fix For: 2.0.0-beta-1
>
>         Attachments: hbase-18961.master.001.patch, hbase-18961.master.002.patch, hbase-18961.master.003.patch
>
>
> Split doMiniBatchMutate() and improve readability.



--
This message was sent by Atlassian JIRA
(v6.4.14#64029)

Mime
View raw message