hbase-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Sean Busbey (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (HBASE-19018) Use of hadoop internals that require bouncycastle should declare bouncycastle dependency
Date Mon, 23 Oct 2017 14:13:00 GMT

    [ https://issues.apache.org/jira/browse/HBASE-19018?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=16215192#comment-16215192
] 

Sean Busbey commented on HBASE-19018:
-------------------------------------

failure:

{code}

[ERROR] Error occurred in starting fork, check output in log
[ERROR] Process Exit Code: 1
[ERROR] Crashed tests:
[ERROR] org.apache.hadoop.hbase.quotas.TestSpaceQuotas
{code}

{code}

[ERROR] Error occurred in starting fork, check output in log
[ERROR] Process Exit Code: 1
[ERROR] Crashed tests:
[ERROR] org.apache.hadoop.hbase.quotas.TestSuperUserQuotaPermissions
{code}

{code}

[ERROR] Error occurred in starting fork, check output in log
[ERROR] Process Exit Code: 1
[ERROR] Crashed tests:
[ERROR] org.apache.hadoop.hbase.quotas.TestQuotaObserverChoreWithMiniCluster
{code}


> Use of hadoop internals that require bouncycastle should declare bouncycastle dependency
> ----------------------------------------------------------------------------------------
>
>                 Key: HBASE-19018
>                 URL: https://issues.apache.org/jira/browse/HBASE-19018
>             Project: HBase
>          Issue Type: Bug
>          Components: dependencies, test
>    Affects Versions: 2.0.0-alpha-3
>            Reporter: Sean Busbey
>            Assignee: Sean Busbey
>            Priority: Critical
>             Fix For: 2.0.0-alpha-4
>
>         Attachments: HBASE-19018.0.patch
>
>
> The tests for HBASE-15806 rely on a Hadoop internal class, {{KeyStoreTestUtil}}, which
in turn relies on the Bouncycastle library for certificate generation.
> when building / running with Hadoop 2.7.1, we accidentally get a bouncycastle implementation
via a transitive dependency of {{hadoop-minikdc}}. When attempting to run against Hadoop 3.0.0-alpha4
and 3.0.0-beta1 (and presumably future Hadoop 3.y releases), this bouncycastle jar is no longer
pulled in and we fail with a CNFE.



--
This message was sent by Atlassian JIRA
(v6.4.14#64029)

Mime
View raw message