hbase-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Umesh Agashe (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (HBASE-18961) doMiniBatchMutate() is big, split it into smaller methods
Date Wed, 18 Oct 2017 21:11:01 GMT

    [ https://issues.apache.org/jira/browse/HBASE-18961?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=16210050#comment-16210050

Umesh Agashe commented on HBASE-18961:

bq. add a function batchOp.isOperationPending() for it.
Done. Also added helper function for visiting all / pending operations with Visitor.

bq. "writeEntry" only seems to be used for non-reply case. Can we rename it to make it explicit?
And return null from doWALAppend when it's replay mode?
writeEntry is need for replay case also for mvcc.complete(). Can not return null from doWALAppend()

bq. In all earlier cases of doWALAppend(), WALEdit was checked to be non-empty. Make keep
that invariant (and even add precondition check for it in the function).

bq. move writeRequestsCount to doMiniBatchMutation. Right now, if the operation actually fails
with exception, we are still incrementing that counter.
Looks like it tracks count request received. It doesn't matter if we process it or not.

bq. In batchMutate(), can we move initialization section out of while(isDone()) loop.
This will change the logic. Currently checkReadOnly() and checkResources() are called once
before pre CP hooks are called. Without duplication initialization section cannot be moved.

> doMiniBatchMutate() is big, split it into smaller methods
> ---------------------------------------------------------
>                 Key: HBASE-18961
>                 URL: https://issues.apache.org/jira/browse/HBASE-18961
>             Project: HBase
>          Issue Type: Sub-task
>          Components: regionserver
>    Affects Versions: 2.0.0-alpha-3
>            Reporter: Umesh Agashe
>            Assignee: Umesh Agashe
>             Fix For: 2.0.0-beta-1
> Split doMiniBatchMutate() and improve readability.

This message was sent by Atlassian JIRA

View raw message