hbase-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Anoop Sam John (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (HBASE-13346) Clean up Filter package for post 1.0 s/KeyValue/Cell/g
Date Wed, 18 Oct 2017 04:30:00 GMT

    [ https://issues.apache.org/jira/browse/HBASE-13346?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=16208798#comment-16208798
] 

Anoop Sam John commented on HBASE-13346:
----------------------------------------

Patch V8 LGTM.   
FilterWrapper also non exposed private class.  Same thing did for ACL filter etc is enough
for this too!..   Not sure why we added this wrapper in client module . It can be in server
module.  Can we move that also as part of this patch?  Any concerns from others working in
Filter cleanup/fix area?

> Clean up Filter package for post 1.0 s/KeyValue/Cell/g
> ------------------------------------------------------
>
>                 Key: HBASE-13346
>                 URL: https://issues.apache.org/jira/browse/HBASE-13346
>             Project: HBase
>          Issue Type: Bug
>          Components: API, Filters
>    Affects Versions: 2.0.0
>            Reporter: Lars George
>            Assignee: Tamas Penzes
>            Priority: Critical
>             Fix For: 2.0.0-alpha-4
>
>         Attachments: HBASE-13346.master.001.patch, HBASE-13346.master.002.patch, HBASE-13346.master.003.patch,
HBASE-13346.master.003.patch, HBASE-13346.master.004.patch, HBASE-13346.master.005.patch,
HBASE-13346.master.006.patch, HBASE-13346.master.007.patch, HBASE-13346.master.008.patch
>
>
> Since we have a bit of a messy Filter API with KeyValue vs Cell reference mixed up all
over the place, I recommend cleaning this up once and for all. There should be no {{KeyValue}}
(or {{kv}}, {{kvs}} etc.) in any method or parameter name.
> This includes deprecating and renaming filters too, for example {{FirstKeyOnlyFilter}},
which really should be named {{FirstKeyValueFilter}} as it does _not_ just return the key,
but the entire cell. It should be deprecated and renamed to {{FirstCellFilter}} (or {{FirstColumnFilter}}
if you prefer).
> In general we should clarify and settle on {{KeyValue}} vs {{Cell}} vs {{Column}} in
our naming. The latter two are the only ones going forward with the public API, and are used
synonymous. We should carefully check which is better suited (is it really a specific cell,
or the newest cell, aka the newest column value) and settle on a naming schema.



--
This message was sent by Atlassian JIRA
(v6.4.14#64029)

Mime
View raw message