hbase-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Chia-Ping Tsai (JIRA)" <j...@apache.org>
Subject [jira] [Updated] (HBASE-18897) Substitute MemStore for Memstore
Date Thu, 28 Sep 2017 17:23:00 GMT

     [ https://issues.apache.org/jira/browse/HBASE-18897?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

Chia-Ping Tsai updated HBASE-18897:
-----------------------------------
    Release Note: 

The changes of IA.Public/IA.LimitedPrivate classes are shown below:
HTableDescriptor class
* boolean hasRegionMemstoreReplication()
+ boolean hasRegionMemStoreReplication()
* HTableDescriptor setRegionMemstoreReplication(boolean) 
+ HTableDescriptor setRegionMemStoreReplication(boolean) 

RegionLoadStats class
* int getMemstoreLoad()
+ int getMemStoreLoad()

ServerLoad class
* int getMemstoreSizeInMB()
+ int getMemStoreSizeInMB()

Region class
- long getMemstoreSize()
+ long getMemStoreSize()

Store class
- MemstoreSize getMemStoreSize()
+ MemStoreSize getMemStoreSize()
- MemstoreSize getFlushableSize()
+ MemStoreSize getFlushableSize()
- MemstoreSize getSnapshotSize()
+ MemStoreSize getSnapshotSize()

StoreFile class
- long getMaxMemstoreTS()
+ long getMaxMemStoreTS()

> Substitute MemStore for Memstore
> --------------------------------
>
>                 Key: HBASE-18897
>                 URL: https://issues.apache.org/jira/browse/HBASE-18897
>             Project: HBase
>          Issue Type: Task
>            Reporter: Chia-Ping Tsai
>            Assignee: Chia-Ping Tsai
>             Fix For: 2.0.0
>
>         Attachments: HBASE-18897.v0.patch
>
>
> Memstore/MemStore is our core component, but we have two ways of writing its name. We
should unify its name in our code base.
> Change the both of Class and APIs only.



--
This message was sent by Atlassian JIRA
(v6.4.14#64029)

Mime
View raw message