hbase-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Thoralf Gutierrez (JIRA)" <j...@apache.org>
Subject [jira] [Comment Edited] (HBASE-18842) The hbase shell clone_snaphost command returns bad error message
Date Sat, 23 Sep 2017 21:48:00 GMT

    [ https://issues.apache.org/jira/browse/HBASE-18842?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=16177977#comment-16177977
] 

Thoralf Gutierrez edited comment on HBASE-18842 at 9/23/17 9:47 PM:
--------------------------------------------------------------------

This patch adds a handler for the `NamespaceNotFoundException` in the `clone_snapshot` command.

Tested locally on the `branch-1.4` branch against a production HBase 1.4 cluster.

The patch should also be applied on master (the problem is still there and the fix is exactly
the same) but somehow I am having difficulties running HBase from the master branch locally,
so I haven't been able to test it there yet.


was (Author: thorgutierrez):
This patch adds a handler for the `NamespaceNotFoundException` in the `clone_snapshot` command.

Tested locally on the `branch-1.4` branch against a production HBase 1.4 cluster.

The patch should also be applied on master but somehow I am having difficulties running HBase
from the master branch locally, so I haven't been able to test it there yet.

> The hbase shell clone_snaphost command returns bad error message
> ----------------------------------------------------------------
>
>                 Key: HBASE-18842
>                 URL: https://issues.apache.org/jira/browse/HBASE-18842
>             Project: HBase
>          Issue Type: Bug
>            Reporter: Thoralf Gutierrez
>            Assignee: Jesse Yates
>            Priority: Minor
>         Attachments: 0001-HBASE-18842-Fix-unknown-namespace-message-in-clone_s.patch
>
>
> When you call the hbase shell clone_snapshot command with a target namespace that doesn't
exist, you get an error message, but the variable used to identify the inexistent namespace
is wrong:
> {noformat}
> hbase(main):001:0> clone_snapshot 'someSnapshotName', 'someNamespaceName:someTableName'
> ERROR: Unknown namespace someSnapshotName!
> Create a new table by cloning the snapshot content.
> There're no copies of data involved.
> And writing on the newly created table will not influence the snapshot data.
> Examples:
>   hbase> clone_snapshot 'snapshotName', 'tableName'
>   hbase> clone_snapshot 'snapshotName', 'namespace:tableName'
> {noformat}
> It should rather say:
> {noformat}
> ERROR: Unknown namespace someNamespaceName!
> {noformat}



--
This message was sent by Atlassian JIRA
(v6.4.14#64029)

Mime
View raw message