hbase-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Jesse Yates (JIRA)" <j...@apache.org>
Subject [jira] [Assigned] (HBASE-18842) The hbase shell clone_snaphost command returns bad error message
Date Mon, 18 Sep 2017 22:40:00 GMT

     [ https://issues.apache.org/jira/browse/HBASE-18842?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

Jesse Yates reassigned HBASE-18842:
-----------------------------------

    Assignee: Jesse Yates

> The hbase shell clone_snaphost command returns bad error message
> ----------------------------------------------------------------
>
>                 Key: HBASE-18842
>                 URL: https://issues.apache.org/jira/browse/HBASE-18842
>             Project: HBase
>          Issue Type: Bug
>            Reporter: Thoralf Gutierrez
>            Assignee: Jesse Yates
>            Priority: Minor
>
> When you call the hbase shell clone_snapshot command with a target namespace that doesn't
exist, you get an error message, but the variable used to identify the inexistent namespace
is wrong:
> {noformat}
> hbase(main):001:0> clone_snapshot 'someSnapshotName', 'someNamespaceName:someTableName'
> ERROR: Unknown namespace someSnapshotName!
> Create a new table by cloning the snapshot content.
> There're no copies of data involved.
> And writing on the newly created table will not influence the snapshot data.
> Examples:
>   hbase> clone_snapshot 'snapshotName', 'tableName'
>   hbase> clone_snapshot 'snapshotName', 'namespace:tableName'
> {noformat}
> It should rather say:
> {noformat}
> ERROR: Unknown namespace someNamespaceName!
> {noformat}



--
This message was sent by Atlassian JIRA
(v6.4.14#64029)

Mime
View raw message