hbase-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Thoralf Gutierrez (JIRA)" <j...@apache.org>
Subject [jira] [Created] (HBASE-18842) The hbase shell clone_snaphost command returns bad error message
Date Mon, 18 Sep 2017 22:20:01 GMT
Thoralf Gutierrez created HBASE-18842:
-----------------------------------------

             Summary: The hbase shell clone_snaphost command returns bad error message
                 Key: HBASE-18842
                 URL: https://issues.apache.org/jira/browse/HBASE-18842
             Project: HBase
          Issue Type: Bug
            Reporter: Thoralf Gutierrez
            Priority: Minor


When you call the hbase shell clone_snapshot command with a target namespace that doesn't
exist, you get an error message, but the variable used to identify the inexistent namespace
is wrong:

{noformat}
hbase(main):001:0> clone_snapshot 'someSnapshotName', 'someNamespaceName:someTableName'

ERROR: Unknown namespace someSnapshotName!

Create a new table by cloning the snapshot content.
There're no copies of data involved.
And writing on the newly created table will not influence the snapshot data.

Examples:
  hbase> clone_snapshot 'snapshotName', 'tableName'
  hbase> clone_snapshot 'snapshotName', 'namespace:tableName'
{noformat}

It should rather say:

{noformat}
ERROR: Unknown namespace someNamespaceName!
{noformat}




--
This message was sent by Atlassian JIRA
(v6.4.14#64029)

Mime
View raw message