hbase-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "ramkrishna.s.vasudevan (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (HBASE-18826) Use HStore instead of Store in our own code base and remove unnecessary methods in Store interface
Date Wed, 27 Sep 2017 07:09:00 GMT

    [ https://issues.apache.org/jira/browse/HBASE-18826?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=16182114#comment-16182114
] 

ramkrishna.s.vasudevan commented on HBASE-18826:
------------------------------------------------

Thanks for the patch. Nice refactoring.
Just few suggestions/queries
StoreConfigInformation - is now part of HStore. But some of the APIs in it looks reasonable
to be in Store.java. For eg getStoreFileTtl(). Generally we have seen CPs which impl their
custom TTL logic which may/may not use per store file TTL info. Will that be needed?
Next is ScanInfo can be made CP LimitedPRivate? Anyway it is just a static info on the scan
and its properties. So if we can make it LimitedPRivate then getScanInfo() can still be in
Store? But I found that ScanInfo is totally used internally and none of the CP hooks use it
but having it as a return type may be helpful?
Rest LGTM using only HStore in the code base through out. 
bq.Comparator<Cell> getComparator();
This is great. I think similar change may be needed else where too like Region, StoreFile
etc. If already done fine then.
+1 overall from me.

> Use HStore instead of Store in our own code base and remove unnecessary methods in Store
interface
> --------------------------------------------------------------------------------------------------
>
>                 Key: HBASE-18826
>                 URL: https://issues.apache.org/jira/browse/HBASE-18826
>             Project: HBase
>          Issue Type: Sub-task
>          Components: Coprocessors
>            Reporter: Duo Zhang
>            Assignee: Duo Zhang
>             Fix For: 2.0.0-alpha-4
>
>         Attachments: HBASE-18826.patch, HBASE-18826-v1.patch, HBASE-18826-v1.patch, HBASE-18826-v2.patch,
HBASE-18826-v3.patch, HBASE-18826-v4.patch
>
>




--
This message was sent by Atlassian JIRA
(v6.4.14#64029)

Mime
View raw message