hbase-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Anoop Sam John (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (HBASE-18825) Use HStoreFile instead of StoreFile in our own code base and remove unnecessary methods in StoreFile interface
Date Wed, 20 Sep 2017 10:16:03 GMT

    [ https://issues.apache.org/jira/browse/HBASE-18825?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=16172973#comment-16172973
] 

Anoop Sam John commented on HBASE-18825:
----------------------------------------

What I said in 1st part of my reply is
bq.For StoreFile, Store, and Region, we will not have multiple implementation classes so it
is not necessary to have an interface for us.
bq.This is not fully true. Though am not sure any one will use, but we do have a config to
plugin region impl. "hbase.hregion.impl". This is in place from long time
So we will have to stop this config way now..  Just saying that.
On the UT aspect , at least for the HRS we can not do impl change in our code base. The current
way of mocking in UTs are more understandable and lets continue.
On StoreFile, may be the mocking way will never be needed.  Same may be with Store and even
Region also.. So we can consider case by case.

> Use HStoreFile instead of StoreFile in our own code base and remove unnecessary methods
in StoreFile interface
> --------------------------------------------------------------------------------------------------------------
>
>                 Key: HBASE-18825
>                 URL: https://issues.apache.org/jira/browse/HBASE-18825
>             Project: HBase
>          Issue Type: Sub-task
>          Components: Coprocessors
>            Reporter: Duo Zhang
>            Assignee: Duo Zhang
>             Fix For: 2.0.0-alpha-4
>
>         Attachments: HBASE-18825.patch, HBASE-18825-v1.patch, HBASE-18825-v2.patch, HBASE-18825-v3.patch,
HBASE-18825-v3.patch
>
>
> Use generic types to avoid too many casts.



--
This message was sent by Atlassian JIRA
(v6.4.14#64029)

Mime
View raw message