hbase-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Duo Zhang (JIRA)" <j...@apache.org>
Subject [jira] [Reopened] (HBASE-18821) Enforcer plugin NPEs again when generating site
Date Fri, 15 Sep 2017 07:40:00 GMT

     [ https://issues.apache.org/jira/browse/HBASE-18821?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

Duo Zhang reopened HBASE-18821:
-------------------------------

Seems this patch breaks m2e
{noformat}
Cannot parse lifecycle mapping metadata for maven project MavenProject: org.apache.hbase:hbase:3.0.0-SNAPSHOT
@ /home/zhangduo/hbase/code/pom.xml Cause: Unrecognised tag: 'version' (position: START_TAG
seen ...</artifactId>\n        <version>... @21:18) 
{noformat}

Seems under pluginExecutionFilter we only allow specifying versionRange, not version.

https://github.com/apache/hbase/commit/fb3c8bf6087b1d9e086a6becd1c0e518cb1f8936#diff-600376dffeb79835ede4a0b285078036L815

Let's change it to
{code}
<versionRange>[${enforcer.version},)</versionRange>
{code}

Thanks.

> Enforcer plugin NPEs again when generating site
> -----------------------------------------------
>
>                 Key: HBASE-18821
>                 URL: https://issues.apache.org/jira/browse/HBASE-18821
>             Project: HBase
>          Issue Type: Sub-task
>          Components: site
>    Affects Versions: 2.0.0-alpha-3
>            Reporter: stack
>            Assignee: stack
>             Fix For: 2.0.0-alpha-3
>
>
> The parent issue came back, HBASE-17351. Using 1.4.1 version of plugin NPEs. Specify
1.4.  I played w/ the suggestions over in MENFORCER-248 but to no avail. There is a jenkins
repository with a 1.4.2 which probably fixes this and then there is the new 3.0.0 stuff....
 Need to come back here. For now, let me get a fix in so can make progress on releases.



--
This message was sent by Atlassian JIRA
(v6.4.14#64029)

Mime
View raw message