hbase-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Appy (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (HBASE-18697) Need a shaded hbase-mapreduce module
Date Tue, 05 Sep 2017 21:51:12 GMT

    [ https://issues.apache.org/jira/browse/HBASE-18697?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=16154425#comment-16154425
] 

Appy commented on HBASE-18697:
------------------------------

what command did you run for that dependency tree? 
coz when i run
{{mvn -f ~/.m2/repository/org/apache/hbase/hbase-shaded-mapreduce/3.0.0-SNAPSHOT/hbase-shaded-mapreduce-3.0.0-SNAPSHOT.pom
dependency:tree}},
i still get a huge deps tree and what I pasted in my previous response was just the part which
is at same hierarchical level as {{org.apache.hbase:hbase-mapreduce:jar:3.0.0-SNAPSHOT:compile}}

Here's the full output, but comparing it to what you pasted, i think it's not the right one
i should be looking at.
{noformat}
[INFO] --- maven-dependency-plugin:3.0.1:tree (default-cli) @ hbase-shaded-mapreduce ---
[INFO] org.apache.hbase:hbase-shaded-mapreduce:jar:3.0.0-SNAPSHOT
[INFO] +- org.apache.hbase:hbase-mapreduce:jar:3.0.0-SNAPSHOT:compile
[INFO] |  +- org.apache.hbase.thirdparty:hbase-shaded-miscellaneous:jar:1.0.1:compile
[INFO] |  +- org.apache.hbase.thirdparty:hbase-shaded-netty:jar:1.0.1:compile
[INFO] |  +- org.apache.hbase.thirdparty:hbase-shaded-protobuf:jar:1.0.1:compile
[INFO] |  +- org.apache.hbase:hbase-annotations:jar:3.0.0-SNAPSHOT:compile
[INFO] |  +- org.apache.hbase:hbase-common:jar:3.0.0-SNAPSHOT:compile
[INFO] |  |  +- commons-codec:commons-codec:jar:1.10:compile
[INFO] |  |  +- commons-collections:commons-collections:jar:3.2.2:compile
[INFO] |  |  +- org.apache.commons:commons-crypto:jar:1.0.0:compile
[INFO] |  |  \- com.github.stephenc.findbugs:findbugs-annotations:jar:1.3.9-1:compile
[INFO] |  +- org.apache.hbase:hbase-protocol:jar:3.0.0-SNAPSHOT:compile
[INFO] |  +- com.google.protobuf:protobuf-java:jar:2.5.0:compile
[INFO] |  +- org.apache.hbase:hbase-protocol-shaded:jar:3.0.0-SNAPSHOT:compile
[INFO] |  +- org.apache.hbase:hbase-metrics:jar:3.0.0-SNAPSHOT:compile
[INFO] |  +- org.apache.hbase:hbase-metrics-api:jar:3.0.0-SNAPSHOT:compile
[INFO] |  +- io.dropwizard.metrics:metrics-core:jar:3.2.1:compile
[INFO] |  +- org.slf4j:slf4j-api:jar:1.7.24:compile
[INFO] |  +- org.apache.hbase:hbase-prefix-tree:jar:3.0.0-SNAPSHOT:runtime
[INFO] |  |  \- org.apache.hbase:hbase-common:jar:tests:3.0.0-SNAPSHOT:test
[INFO] |  +- org.apache.htrace:htrace-core:jar:3.2.0-incubating:compile
[INFO] |  +- org.apache.hbase:hbase-client:jar:3.0.0-SNAPSHOT:compile
[INFO] |  |  +- org.jruby.jcodings:jcodings:jar:1.0.18:compile
[INFO] |  |  +- org.jruby.joni:joni:jar:2.1.11:compile
[INFO] |  |  +- org.apache.curator:curator-framework:jar:2.12.0:compile
[INFO] |  |  +- org.apache.curator:curator-client:jar:2.12.0:compile
[INFO] |  |  \- org.apache.hadoop:hadoop-auth:jar:2.7.1:compile
[INFO] |  |     +- org.apache.httpcomponents:httpclient:jar:4.5.3:compile
[INFO] |  |     \- org.apache.directory.server:apacheds-kerberos-codec:jar:2.0.0-M15:compile
[INFO] |  |        +- org.apache.directory.server:apacheds-i18n:jar:2.0.0-M15:compile
[INFO] |  |        +- org.apache.directory.api:api-asn1-api:jar:1.0.0-M20:compile
[INFO] |  |        \- org.apache.directory.api:api-util:jar:1.0.0-M20:compile
[INFO] |  +- org.apache.hbase:hbase-hadoop-compat:jar:3.0.0-SNAPSHOT:compile
[INFO] |  +- org.apache.hbase:hbase-hadoop2-compat:jar:3.0.0-SNAPSHOT:compile
[INFO] |  +- org.apache.hbase:hbase-server:jar:3.0.0-SNAPSHOT:compile
[INFO] |  |  +- org.apache.hbase:hbase-procedure:jar:3.0.0-SNAPSHOT:compile
[INFO] |  |  +- org.eclipse.jetty:jetty-http:jar:9.4.6.v20170531:compile
[INFO] |  |  |  \- org.eclipse.jetty:jetty-io:jar:9.4.6.v20170531:compile
[INFO] |  |  +- org.eclipse.jetty:jetty-security:jar:9.4.6.v20170531:compile
[INFO] |  |  +- org.glassfish.web:javax.servlet.jsp:jar:2.3.2:compile
[INFO] |  |  |  +- org.glassfish:javax.el:jar:3.0.1-b08:compile (version selected from constraint
[3.0.0,))
[INFO] |  |  |  \- javax.servlet.jsp:javax.servlet.jsp-api:jar:2.3.1:compile
[INFO] |  |  +- org.codehaus.jettison:jettison:jar:1.3.8:compile
[INFO] |  |  +- org.apache.commons:commons-math:jar:2.2:compile
[INFO] |  |  +- org.jamon:jamon-runtime:jar:2.4.1:compile
[INFO] |  |  +- javax.servlet:javax.servlet-api:jar:3.1.0:compile
[INFO] |  |  +- com.lmax:disruptor:jar:3.3.6:compile
[INFO] |  |  +- org.apache.hadoop:hadoop-distcp:jar:2.7.1:compile
[INFO] |  |  +- org.apache.hadoop:hadoop-annotations:jar:2.7.1:compile
[INFO] |  |  |  \- jdk.tools:jdk.tools:jar:1.8:system
[INFO] |  |  \- org.apache.hadoop:hadoop-client:jar:2.7.1:compile
[INFO] |  |     +- org.apache.hadoop:hadoop-mapreduce-client-app:jar:2.7.1:compile
[INFO] |  |     |  +- org.apache.hadoop:hadoop-mapreduce-client-common:jar:2.7.1:compile
[INFO] |  |     |  |  +- org.apache.hadoop:hadoop-yarn-client:jar:2.7.1:compile
[INFO] |  |     |  |  \- org.apache.hadoop:hadoop-yarn-server-common:jar:2.7.1:compile
[INFO] |  |     |  \- org.apache.hadoop:hadoop-mapreduce-client-shuffle:jar:2.7.1:compile
[INFO] |  |     +- org.apache.hadoop:hadoop-yarn-api:jar:2.7.1:compile
[INFO] |  |     \- org.apache.hadoop:hadoop-mapreduce-client-jobclient:jar:2.7.1:compile
[INFO] |  +- org.apache.hbase:hbase-replication:jar:3.0.0-SNAPSHOT:compile
[INFO] |  +- commons-cli:commons-cli:jar:1.4:compile
[INFO] |  +- commons-io:commons-io:jar:2.5:compile
[INFO] |  +- org.apache.commons:commons-lang3:jar:3.6:compile
[INFO] |  +- commons-logging:commons-logging:jar:1.2:compile
[INFO] |  +- org.apache.zookeeper:zookeeper:jar:3.4.10:compile
[INFO] |  +- org.codehaus.jackson:jackson-core-asl:jar:1.9.13:compile
[INFO] |  +- org.codehaus.jackson:jackson-mapper-asl:jar:1.9.13:compile
[INFO] |  +- org.apache.hadoop:hadoop-common:jar:2.7.1:compile
[INFO] |  |  +- com.google.guava:guava:jar:11.0.2:compile
[INFO] |  |  +- org.apache.commons:commons-math3:jar:3.1.1:compile
[INFO] |  |  +- xmlenc:xmlenc:jar:0.52:compile
[INFO] |  |  +- commons-httpclient:commons-httpclient:jar:3.1:compile
[INFO] |  |  +- commons-net:commons-net:jar:3.1:compile
[INFO] |  |  +- org.mortbay.jetty:jetty-util:jar:6.1.26:compile
[INFO] |  |  +- commons-lang:commons-lang:jar:2.6:compile
[INFO] |  |  +- commons-configuration:commons-configuration:jar:1.6:compile
[INFO] |  |  |  +- commons-digester:commons-digester:jar:1.8:compile
[INFO] |  |  |  \- commons-beanutils:commons-beanutils-core:jar:1.8.0:compile
[INFO] |  |  +- org.apache.avro:avro:jar:1.7.7:compile
[INFO] |  |  |  +- com.thoughtworks.paranamer:paranamer:jar:2.3:compile
[INFO] |  |  |  \- org.xerial.snappy:snappy-java:jar:1.0.5:compile
[INFO] |  |  +- com.google.code.gson:gson:jar:2.2.4:compile
[INFO] |  |  +- com.jcraft:jsch:jar:0.1.42:compile
[INFO] |  |  +- org.apache.curator:curator-recipes:jar:2.12.0:compile
[INFO] |  |  \- org.apache.commons:commons-compress:jar:1.4.1:compile
[INFO] |  |     \- org.tukaani:xz:jar:1.0:compile
[INFO] |  +- org.apache.hadoop:hadoop-hdfs:jar:2.7.1:compile
[INFO] |  |  +- org.mortbay.jetty:jetty:jar:6.1.26:compile
[INFO] |  |  +- commons-daemon:commons-daemon:jar:1.0.13:compile
[INFO] |  |  +- io.netty:netty-all:jar:4.0.23.Final:compile
[INFO] |  |  \- org.fusesource.leveldbjni:leveldbjni-all:jar:1.8:compile
[INFO] |  \- org.apache.hadoop:hadoop-mapreduce-client-core:jar:2.7.1:compile
[INFO] |     +- org.apache.hadoop:hadoop-yarn-common:jar:2.7.1:compile
[INFO] |     |  +- org.codehaus.jackson:jackson-jaxrs:jar:1.9.13:compile
[INFO] |     |  +- org.codehaus.jackson:jackson-xc:jar:1.9.13:compile
[INFO] |     |  \- com.google.inject:guice:jar:3.0:compile
[INFO] |     |     \- aopalliance:aopalliance:jar:1.0:compile
[INFO] |     \- com.google.inject.extensions:guice-servlet:jar:3.0:compile
[INFO] +- org.apache.hbase:hbase-resource-bundle:jar:3.0.0-SNAPSHOT:compile (optional)
[INFO] +- log4j:log4j:jar:1.2.17:compile
[INFO] +- org.slf4j:slf4j-log4j12:jar:1.7.24:compile (optional)
[INFO] \- junit:junit:jar:4.12:compile
[INFO]    \- org.hamcrest:hamcrest-core:jar:1.3:test
{noformat}


> Need a shaded hbase-mapreduce module
> ------------------------------------
>
>                 Key: HBASE-18697
>                 URL: https://issues.apache.org/jira/browse/HBASE-18697
>             Project: HBase
>          Issue Type: Sub-task
>          Components: mapreduce
>            Reporter: Duo Zhang
>            Assignee: Appy
>             Fix For: 3.0.0, 2.0.0-alpha-3
>
>         Attachments: HBASE-18697.master.001.patch, HBASE-18697.master.002.patch, HBASE-18697.master.003.patch
>
>




--
This message was sent by Atlassian JIRA
(v6.4.14#64029)

Mime
View raw message