hbase-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "stack (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (HBASE-14998) Unify synchronous and asynchronous methods in Admin and cleanup
Date Tue, 12 Sep 2017 17:38:00 GMT

    [ https://issues.apache.org/jira/browse/HBASE-14998?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=16163334#comment-16163334

stack commented on HBASE-14998:

bq. I agree that optional is a nice stuff, but we can also use @Nullable to mark parameters
as optional.

An Annotation instead of a Type? Would @Nullable be used in Admin or in both Admin and AsyncAdmin?

Agree, List is better than array so reluctant to change AsyncAdmin to return arrays instead.
Let me look.

Thanks [~balazs.meszaros]

> Unify synchronous and asynchronous methods in Admin and cleanup
> ---------------------------------------------------------------
>                 Key: HBASE-14998
>                 URL: https://issues.apache.org/jira/browse/HBASE-14998
>             Project: HBase
>          Issue Type: Sub-task
>            Reporter: Enis Soztutar
>            Assignee: Balazs Meszaros
>            Priority: Blocker
>             Fix For: 2.0.0-alpha-3
>         Attachments: 14998.txt
> Admin has a bunch of methods, some are asnyc, some are sync. Needs some unification in
method naming, and method signatures. 
>  - We use modify and alter interchangeably. Pick one and stick with it (modifyTable(),
versus getAlterStatus()). Shell uses {{alter}}. 
>  - Remove getAlterStatus(), should not be needed. 
>  - remove already deprecated methods 
>  -  isTableAvailable(TableName tableName, byte[][] splitKeys) should be removed. 
>  - Consistently use Aysnc as a prefix for all async methods. 
>  - Other ideas? 

This message was sent by Atlassian JIRA

View raw message