hbase-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Hadoop QA (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (HBASE-13346) Clean up Filter package for post 1.0 s/KeyValue/Cell/g
Date Thu, 21 Sep 2017 13:51:00 GMT

    [ https://issues.apache.org/jira/browse/HBASE-13346?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=16174783#comment-16174783
] 

Hadoop QA commented on HBASE-13346:
-----------------------------------

| (x) *{color:red}-1 overall{color}* |
\\
\\
|| Vote || Subsystem || Runtime || Comment ||
| {color:blue}0{color} | {color:blue} reexec {color} | {color:blue}  0m  0s{color} | {color:blue}
Docker mode activated. {color} |
| {color:red}-1{color} | {color:red} docker {color} | {color:red}499m 54s{color} | {color:red}
Docker failed to build yetus/hbase:5d60123. {color} |
\\
\\
|| Subsystem || Report/Notes ||
| JIRA Issue | HBASE-13346 |
| JIRA Patch URL | https://issues.apache.org/jira/secure/attachment/12888211/HBASE-13346.master.003.patch
|
| Console output | https://builds.apache.org/job/PreCommit-HBASE-Build/8722/console |
| Powered by | Apache Yetus 0.4.0   http://yetus.apache.org |


This message was automatically generated.



> Clean up Filter package for post 1.0 s/KeyValue/Cell/g
> ------------------------------------------------------
>
>                 Key: HBASE-13346
>                 URL: https://issues.apache.org/jira/browse/HBASE-13346
>             Project: HBase
>          Issue Type: Bug
>          Components: API, Filters
>    Affects Versions: 2.0.0
>            Reporter: Lars George
>            Assignee: Tamas Penzes
>            Priority: Critical
>             Fix For: 2.0.0-alpha-4
>
>         Attachments: HBASE-13346.master.001.patch, HBASE-13346.master.002.patch, HBASE-13346.master.003.patch,
HBASE-13346.master.003.patch
>
>
> Since we have a bit of a messy Filter API with KeyValue vs Cell reference mixed up all
over the place, I recommend cleaning this up once and for all. There should be no {{KeyValue}}
(or {{kv}}, {{kvs}} etc.) in any method or parameter name.
> This includes deprecating and renaming filters too, for example {{FirstKeyOnlyFilter}},
which really should be named {{FirstKeyValueFilter}} as it does _not_ just return the key,
but the entire cell. It should be deprecated and renamed to {{FirstCellFilter}} (or {{FirstColumnFilter}}
if you prefer).
> In general we should clarify and settle on {{KeyValue}} vs {{Cell}} vs {{Column}} in
our naming. The latter two are the only ones going forward with the public API, and are used
synonymous. We should carefully check which is better suited (is it really a specific cell,
or the newest cell, aka the newest column value) and settle on a naming schema.



--
This message was sent by Atlassian JIRA
(v6.4.14#64029)

Mime
View raw message