hbase-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Abhishek Singh Chouhan (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (HBASE-13346) Clean up Filter package for post 1.0 s/KeyValue/Cell/g
Date Fri, 15 Sep 2017 11:38:01 GMT

    [ https://issues.apache.org/jira/browse/HBASE-13346?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=16167750#comment-16167750
] 

Abhishek Singh Chouhan commented on HBASE-13346:
------------------------------------------------

[~tamaas] There are a lot of references to kv in the javadoc too. Since this is the public
client API we should cleanup those too to avoid confusion. I haven't looked at part of having
a consistent nomenclature of Cell vs Column in much detail which is also something we should
do, hence created the subtask to do a part of this.

As part of jira hygiene please call out at the earliest if you're doing some work that already
has an assignee (even if its in a subtask) to avoid other people wasting cycles on the same.

You can take over the sub task if you want and have a look at the comments there. I believe
the current patch will break clients.

> Clean up Filter package for post 1.0 s/KeyValue/Cell/g
> ------------------------------------------------------
>
>                 Key: HBASE-13346
>                 URL: https://issues.apache.org/jira/browse/HBASE-13346
>             Project: HBase
>          Issue Type: Bug
>          Components: API, Filters
>    Affects Versions: 2.0.0
>            Reporter: Lars George
>            Assignee: Tamas Penzes
>            Priority: Critical
>             Fix For: 2.0.0-alpha-3
>
>         Attachments: HBASE-13346.master.001.patch
>
>
> Since we have a bit of a messy Filter API with KeyValue vs Cell reference mixed up all
over the place, I recommend cleaning this up once and for all. There should be no {{KeyValue}}
(or {{kv}}, {{kvs}} etc.) in any method or parameter name.
> This includes deprecating and renaming filters too, for example {{FirstKeyOnlyFilter}},
which really should be named {{FirstKeyValueFilter}} as it does _not_ just return the key,
but the entire cell. It should be deprecated and renamed to {{FirstCellFilter}} (or {{FirstColumnFilter}}
if you prefer).
> In general we should clarify and settle on {{KeyValue}} vs {{Cell}} vs {{Column}} in
our naming. The latter two are the only ones going forward with the public API, and are used
synonymous. We should carefully check which is better suited (is it really a specific cell,
or the newest cell, aka the newest column value) and settle on a naming schema.



--
This message was sent by Atlassian JIRA
(v6.4.14#64029)

Mime
View raw message