hbase-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Appy (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (HBASE-18699) Move LoadIncrementalHFiles to another package
Date Tue, 29 Aug 2017 00:20:00 GMT

    [ https://issues.apache.org/jira/browse/HBASE-18699?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=16144584#comment-16144584
] 

Appy commented on HBASE-18699:
------------------------------

I thought of doing that. But the problem is, it's marked IA.Public. I don't think we can break
that compat without marking it deprecated for at least a major version.
So probably we should make this jira about ' deprecate LoadIncrementalHFiles from o.a.h.h.mapreduce
package'.
A simple way would be, move this class to {{o.a.h.h.tools}}, and make current one deprecated
and extend the one in tool. That should work, right?

> Move LoadIncrementalHFiles to another package
> ---------------------------------------------
>
>                 Key: HBASE-18699
>                 URL: https://issues.apache.org/jira/browse/HBASE-18699
>             Project: HBase
>          Issue Type: Sub-task
>          Components: mapreduce
>            Reporter: Duo Zhang
>             Fix For: 3.0.0, 2.0.0-alpha-3
>
>
> LoadIncrementalHFiles does not depend on map reduce.



--
This message was sent by Atlassian JIRA
(v6.4.14#64029)

Mime
View raw message