hbase-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Dima Spivak (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (HBASE-18591) Upgrade thrift from 0.9.3 to 0.10.0
Date Mon, 14 Aug 2017 16:56:00 GMT

    [ https://issues.apache.org/jira/browse/HBASE-18591?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=16125962#comment-16125962
] 

Dima Spivak commented on HBASE-18591:
-------------------------------------

If this needs to be done for Jetty, I think it's worth doing. HappyBase is already only kind
of maintained and lacks a lot of features (e.g. anything security related), so I feel like
if the community has a strong interest in proper Python bindings to Thrift, it can create
them anew with 0.10.0 support.

> Upgrade thrift from 0.9.3 to 0.10.0
> -----------------------------------
>
>                 Key: HBASE-18591
>                 URL: https://issues.apache.org/jira/browse/HBASE-18591
>             Project: HBase
>          Issue Type: Bug
>          Components: Thrift
>            Reporter: stack
>            Assignee: stack
>             Fix For: 2.0.0
>
>         Attachments: 18591.txt
>
>
> Maybe we don't want to do this for 2.0.0. Maybe we want to let it up to the implementor.
Going to 0.10.0 will probably break any 0.9.3 clients. I could try it I suppose but if past
experience is anything to go by...it'll break (There is this note that it is broke up on happybase
https://github.com/wbolster/happybase/issues/154).



--
This message was sent by Atlassian JIRA
(v6.4.14#64029)

Mime
View raw message