hbase-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Appy (JIRA)" <j...@apache.org>
Subject [jira] [Comment Edited] (HBASE-18509) [HLC] Finishing cleanups
Date Wed, 16 Aug 2017 00:29:00 GMT

    [ https://issues.apache.org/jira/browse/HBASE-18509?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=16128145#comment-16128145
] 

Appy edited comment on HBASE-18509 at 8/16/17 12:28 AM:
--------------------------------------------------------

Patch 1 takes care of:
- Rename classes to more consistent naming: SystemClock, SystemMonotonicClock, HybridLogicalClock
- Move implementations out from Clock interface. It's a simple interface of 6 fns but very
overloaded right now with everything put inside it.

Additional changes before commit: Moved out ClockException too. Added InterfaceAudience to
new classes.
Committed.
Keeping jira open for remaining cleanup work.



was (Author: appy):
Patch 1 takes care of:
- Rename classes to more consistent naming: SystemClock, SystemMonotonicClock, HybridLogicalClock
- Move implementations out from Clock interface. It's a simple interface of 6 fns but very
overloaded right now with everything put inside it.
Additional changes before commit: Moved out ClockException too. Added InterfaceAudience to
new classes.
Committed.
Keeping jira open for remaining cleanup work.


> [HLC] Finishing cleanups
> ------------------------
>
>                 Key: HBASE-18509
>                 URL: https://issues.apache.org/jira/browse/HBASE-18509
>             Project: HBase
>          Issue Type: Sub-task
>            Reporter: Appy
>            Assignee: Amit Patel
>         Attachments: HBASE-18509.HBASE-14070.HLC.001.patch
>
>
> Track all types of cleanups here:
> - Rename classes to more consistent naming: SystemClock, SystemMonotonicClock, HybridLogicalClock
> - Move implementations out from Clock interface. It's a simple interface of 6 fns but
very overloaded right now with everything put inside it.
> - Maybe encapsulate all clocks in RS/Master into a new class. Then RSServices can just
have getClocks() function.
> {noformat}
> class Clocks {
>   // all 3 types of clocks.
>   // Fns:
>   - update(ClockType, timestamp)
>   - updateAll(List\<NodeTime>)
>   - int64 now(ClockType)
>   - List\<NodeTime> nowAll()
>   }
> {noformat}



--
This message was sent by Atlassian JIRA
(v6.4.14#64029)

Mime
View raw message