hbase-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Josh Elser (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (HBASE-18387) [Thrift] Make principal configurable in DemoClient.java
Date Mon, 07 Aug 2017 21:11:01 GMT

    [ https://issues.apache.org/jira/browse/HBASE-18387?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=16117298#comment-16117298

Josh Elser commented on HBASE-18387:

+            System.out.println("Usage: DemoClient host port [secure=false] [server-principal=hbase]");

I think the parsing could be simplified if instead the arguments were {{DemoClient host port
\[secure=false \[server-principal=hbase\] \]}} (the server principal option can only be provided
if the secure option is also provided). Trying to do optional-positional arguments in the
manner you tried to implement is super confusing, IMO (named args are a bit more clear in
that regard, but I digress).

Any chance I could convince you to tweak this? :)

> [Thrift] Make principal configurable in DemoClient.java
> -------------------------------------------------------
>                 Key: HBASE-18387
>                 URL: https://issues.apache.org/jira/browse/HBASE-18387
>             Project: HBase
>          Issue Type: Improvement
>            Reporter: Lars George
>            Assignee: Tamas Penzes
>            Priority: Minor
>              Labels: beginner
>         Attachments: HBASE-18387.master.001.patch, HBASE-18387.master.002.patch
> In the Thrift1 demo client we have this code:
> {code}
> transport = new TSaslClientTransport("GSSAPI", null,
>   "hbase", // Thrift server user name, should be an authorized proxy user.
>   host, // Thrift server domain
>   saslProperties, null, transport);
> {code}
> This will only work when the Thrift server is started with the {{hbase}} principal. Often
this may deviate, for example I am using {{hbase-thrift}} to separate the names from those
of backend servers. 
> What we need is either an additional command line option to specify the name, or a property
that can be set with -D and can be passed at runtime. I prefer the former, as the latter is
making this a little convoluted.

This message was sent by Atlassian JIRA

View raw message