hbase-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Josh Elser (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (HBASE-18353) Enable TestCorruptedRegionStoreFile that were disabled by Proc-V2 AM in HBASE-14614
Date Wed, 16 Aug 2017 15:37:00 GMT

    [ https://issues.apache.org/jira/browse/HBASE-18353?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=16128963#comment-16128963

Josh Elser commented on HBASE-18353:

bq. And again, what is the scenario you want to leave a region in a CLOSED state?

I've used this in the past to hack together failure-recovery scenarios (e.g. how does a client
respond to a closed region, how does HBCK respond).

bq. You can have the state internally, but I do not think we should expose this to user. It
is confusing. 

I'd agree, deprecating {{Admin#offline()}} would be a good idea. I can't think of a case when
a "normal" user would want to use {{offline()}} and not {{reassign()}}.

bq. Maybe we should just rename the unassign method to reassign, and implement the unassign
and assign logic in that method?

The other suggestion would be to rename {{Admin#unassign()}} to {{Admin#reassign()}}. This
can be done with a deprecation of {{unassign()}} for branch-2 (and branch-1? I forget without
re-reading policy). Duo, are you suggesting that we also have to change the implementation

It seems like this just got bogged down in nomenclature. Let me try to help hash this out

> Enable TestCorruptedRegionStoreFile that were disabled by Proc-V2 AM in HBASE-14614
> -----------------------------------------------------------------------------------
>                 Key: HBASE-18353
>                 URL: https://issues.apache.org/jira/browse/HBASE-18353
>             Project: HBase
>          Issue Type: Bug
>          Components: test
>    Affects Versions: 2.0.0-alpha-1
>            Reporter: Stephen Yuan Jiang
>            Assignee: Vladimir Rodionov
>         Attachments: HBASE-18353-v1.patch, HBASE-18353-v2.patch
> HBASE-14614 disabled TestCorruptedRegionStoreFile, as it depends on a half-implemented
reopen of a region when a store file goes missing.
> This JIRA tracks the work to fix/enable the test.

This message was sent by Atlassian JIRA

View raw message