hbase-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Chia-Ping Tsai (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (HBASE-2631) Decide between "InMB" and "MB" as suffix for field names in ClusterStatus objects
Date Sun, 13 Aug 2017 17:10:00 GMT

    [ https://issues.apache.org/jira/browse/HBASE-2631?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=16124985#comment-16124985
] 

Chia-Ping Tsai commented on HBASE-2631:
---------------------------------------

{code}
+  /**
+   * @deprecated Use unity naming for SizeMB of ClusterStatus object in HBASE-2631
+   */
{code}
Please add the comment about the substitute and the version to remove. I leave an example
for your reference.
{code}
   * @deprecated As of release 2.0.0, this will be removed in HBase 3.0.0.
   *             Use {@link #getStorefileIndexSizeMB()} instead
{code}

> Decide between "InMB" and "MB" as suffix for field names in ClusterStatus objects
> ---------------------------------------------------------------------------------
>
>                 Key: HBASE-2631
>                 URL: https://issues.apache.org/jira/browse/HBASE-2631
>             Project: HBase
>          Issue Type: Improvement
>            Reporter: Jeff Hammerbacher
>            Assignee: Deon Huang
>              Labels: beginner
>             Fix For: 2.0.0-alpha-2
>
>         Attachments: HBASE-2631.branch-2.v0.patch
>
>
> We vacillate between "InMB" (e.g. HServerLoad.getMemStoreSizeInMB(), HServerLoad.getStorefileIndexSizeInMB())
and "MB" (e.g. HServerLoad.getUsedHeapMB()) in the various ClusterStatus objects (HServerInfo,
HServerLoad, HServerLoad.RegionLoad). We should probably pick one and stick to it.



--
This message was sent by Atlassian JIRA
(v6.4.14#64029)

Mime
View raw message