hbase-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Mike Drob (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (HBASE-18445) Upgrading Guava broke hadoop-3.0 profile
Date Tue, 25 Jul 2017 19:07:00 GMT

    [ https://issues.apache.org/jira/browse/HBASE-18445?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=16100576#comment-16100576
] 

Mike Drob commented on HBASE-18445:
-----------------------------------

Realized that precommit isn't going to test this against hadoop 3, so that result is largely
meaningless.

What do you think is a good set of tests to run, [~stack]?

> Upgrading Guava broke hadoop-3.0 profile
> ----------------------------------------
>
>                 Key: HBASE-18445
>                 URL: https://issues.apache.org/jira/browse/HBASE-18445
>             Project: HBase
>          Issue Type: Bug
>          Components: build, dependencies, hadoop3
>    Affects Versions: 2.0.0-alpha-2
>            Reporter: Mike Drob
>            Assignee: Mike Drob
>            Priority: Blocker
>             Fix For: 2.0.0-alpha-2
>
>         Attachments: HBASE-18445.patch
>
>
> After HBASE-17908 upgrade guava, we have failures with the hadoop-3.0 profile.
> {noformat}
> [INFO] --- maven-enforcer-plugin:1.4.1:enforce (banned-jsr305) @ hbase-client ---
> [WARNING] Rule 0: org.apache.maven.plugins.enforcer.BannedDependencies failed with message:
> We don't allow the JSR305 jar from the Findbugs project, see HBASE-16321.
> Found Banned Dependency: com.google.code.findbugs:jsr305:jar:1.3.9
> Use 'mvn dependency:tree' to locate the source of the banned dependencies.
> {noformat}
> {noformat}
> [INFO] --- maven-dependency-plugin:2.10:tree (default-cli) @ hbase-client ---
> [INFO] org.apache.hbase:hbase-client:jar:2.0.0-alpha-2-SNAPSHOT
> [INFO] +- org.apache.hadoop:hadoop-auth:jar:3.0.0-alpha4:compile
> [INFO] |  +- org.apache.httpcomponents:httpclient:jar:4.5.3:compile
> [INFO] |  |  \- org.apache.httpcomponents:httpcore:jar:4.4.6:compile
> [INFO] |  +- com.nimbusds:nimbus-jose-jwt:jar:3.9:compile
> [INFO] |  |  +- net.jcip:jcip-annotations:jar:1.0:compile
> [INFO] |  |  \- net.minidev:json-smart:jar:1.1.1:compile
> [INFO] |  +- org.apache.kerby:kerb-simplekdc:jar:1.0.0-RC2:compile
> [INFO] |  |  +- org.apache.kerby:kerby-config:jar:1.0.0-RC2:compile
> [INFO] |  |  +- org.apache.kerby:kerb-core:jar:1.0.0-RC2:compile
> [INFO] |  |  |  +- org.apache.kerby:kerby-asn1:jar:1.0.0-RC2:compile
> [INFO] |  |  |  \- org.apache.kerby:kerby-pkix:jar:1.0.0-RC2:compile
> [INFO] |  |  |     \- org.apache.kerby:kerby-util:jar:1.0.0-RC2:compile
> [INFO] |  |  +- org.apache.kerby:kerb-client:jar:1.0.0-RC2:compile
> [INFO] |  |  |  \- org.apache.kerby:kerb-common:jar:1.0.0-RC2:compile
> [INFO] |  |  +- org.apache.kerby:kerb-util:jar:1.0.0-RC2:compile
> [INFO] |  |  |  \- org.apache.kerby:kerb-crypto:jar:1.0.0-RC2:compile
> [INFO] |  |  +- org.apache.kerby:kerb-server:jar:1.0.0-RC2:compile
> [INFO] |  |  |  \- org.apache.kerby:kerb-identity:jar:1.0.0-RC2:compile
> [INFO] |  |  \- org.apache.kerby:kerb-admin:jar:1.0.0-RC2:compile
> [INFO] |  \- com.google.guava:guava:jar:11.0.2:compile
> [INFO] |     \- com.google.code.findbugs:jsr305:jar:1.3.9:compile
> {noformat}



--
This message was sent by Atlassian JIRA
(v6.4.14#64029)

Mime
View raw message