hbase-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Yu Li (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (HBASE-18374) RegionServer Metrics improvements
Date Mon, 31 Jul 2017 04:02:00 GMT

    [ https://issues.apache.org/jira/browse/HBASE-18374?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=16106786#comment-16106786
] 

Yu Li commented on HBASE-18374:
-------------------------------

I could see some incompatible changes on metrics names (such as regionserver.server.mutate
-> regionserver.server.put), which will cause existing monitoring on those metrics not
working anymore after upgrading.

The metrics compatibility is included in "Operational Compatibility" in our [ref guid|http://hbase.apache.org/book.html#hbase.versioning]
and we're allowed to break it in major/minor versions but not in patch versions. So I think
it's ok to go into branch-1/branch-2/master but please fill in the release notes. Thanks.

> RegionServer Metrics improvements
> ---------------------------------
>
>                 Key: HBASE-18374
>                 URL: https://issues.apache.org/jira/browse/HBASE-18374
>             Project: HBase
>          Issue Type: Improvement
>    Affects Versions: 3.0.0
>            Reporter: Abhishek Singh Chouhan
>            Assignee: Abhishek Singh Chouhan
>             Fix For: 3.0.0, 1.4.0, 1.5.0, 2.0.0-alpha-2
>
>         Attachments: HBASE-18374.branch-1.001.patch, HBASE-18374.branch-1.001.patch,
HBASE-18374.branch-1.002.patch, HBASE-18374.branch-1.003.patch, HBASE-18374.master.001.patch,
HBASE-18374.master.002.patch, HBASE-18374.master.003.patch, HBASE-18374.master.004.patch,
HBASE-18374.master.005.patch
>
>
> At the RS level we have latency metrics for mutate/puts and deletes that are updated
per batch (ie. at the end of entire batchop if it contains put/delete update the respective
metric) in contrast with append/increment/get metrics that are updated per op. This is a bit
ambiguous since the delete and put metrics are updated for multi row mutations that happen
to contain a put/delete. We should rename the metric(eg. delete_batch)/add better description.
Also we should add metrics for single delete client operations that come through RSRpcServer.mutate
path. We should also add metrics for checkAndPut and checkAndDelete.



--
This message was sent by Atlassian JIRA
(v6.4.14#64029)

Mime
View raw message