hbase-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Abhishek Singh Chouhan (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (HBASE-18374) RegionServer Metrics improvements
Date Thu, 27 Jul 2017 18:43:00 GMT

    [ https://issues.apache.org/jira/browse/HBASE-18374?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=16103673#comment-16103673
] 

Abhishek Singh Chouhan commented on HBASE-18374:
------------------------------------------------

[~chia7712] Thanks for having a look. Have uploaded new patch including the null check.
Previously the delete metric captured latency of the batch containing delete(this is renamed
to batchDelete to keep the previous behavior although its of little use IMO), the current
put histo also captures the same thing ie. latency of the batch that contains a put, latency
per put is somewhat harder since we go the same way for a single put and batched puts (multi->dobatchmutate),
hence the current behavior.

> RegionServer Metrics improvements
> ---------------------------------
>
>                 Key: HBASE-18374
>                 URL: https://issues.apache.org/jira/browse/HBASE-18374
>             Project: HBase
>          Issue Type: Improvement
>    Affects Versions: 3.0.0
>            Reporter: Abhishek Singh Chouhan
>            Assignee: Abhishek Singh Chouhan
>             Fix For: 3.0.0
>
>         Attachments: HBASE-18374.branch-1.001.patch, HBASE-18374.branch-1.001.patch,
HBASE-18374.master.001.patch, HBASE-18374.master.002.patch, HBASE-18374.master.003.patch,
HBASE-18374.master.004.patch
>
>
> At the RS level we have latency metrics for mutate/puts and deletes that are updated
per batch (ie. at the end of entire batchop if it contains put/delete update the respective
metric) in contrast with append/increment/get metrics that are updated per op. This is a bit
ambiguous since the delete and put metrics are updated for multi row mutations that happen
to contain a put/delete. We should rename the metric(eg. delete_batch)/add better description.
Also we should add metrics for single delete client operations that come through RSRpcServer.mutate
path. We should also add metrics for checkAndPut and checkAndDelete.



--
This message was sent by Atlassian JIRA
(v6.4.14#64029)

Mime
View raw message