hbase-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Andrew Purtell (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (HBASE-18374) RegionServer Metrics improvements
Date Tue, 25 Jul 2017 20:47:00 GMT

    [ https://issues.apache.org/jira/browse/HBASE-18374?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=16100752#comment-16100752
] 

Andrew Purtell commented on HBASE-18374:
----------------------------------------

I'm not convinced we need the new deleteBatch metric, but I makes sense as a nod to backwards
compatibility, maintaining the old behavior, but under a different name. 

The other metrics look useful.

+1 from me

> RegionServer Metrics improvements
> ---------------------------------
>
>                 Key: HBASE-18374
>                 URL: https://issues.apache.org/jira/browse/HBASE-18374
>             Project: HBase
>          Issue Type: Improvement
>    Affects Versions: 3.0.0
>            Reporter: Abhishek Singh Chouhan
>            Assignee: Abhishek Singh Chouhan
>             Fix For: 3.0.0
>
>         Attachments: HBASE-18374.master.001.patch, HBASE-18374.master.002.patch, HBASE-18374.master.003.patch
>
>
> At the RS level we have latency metrics for mutate/puts and deletes that are updated
per batch (ie. at the end of entire batchop if it contains put/delete update the respective
metric) in contrast with append/increment/get metrics that are updated per op. This is a bit
ambiguous since the delete and put metrics are updated for multi row mutations that happen
to contain a put/delete. We should rename the metric(eg. delete_batch)/add better description.
Also we should add metrics for single delete client operations that come through RSRpcServer.mutate
path. We should also add metrics for checkAndPut and checkAndDelete.



--
This message was sent by Atlassian JIRA
(v6.4.14#64029)

Mime
View raw message