hbase-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Hadoop QA (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (HBASE-18182) Setting HBASE_REGIONSERVER_OPTS with UseG1GC will cause regionserver start error
Date Wed, 07 Jun 2017 09:54:18 GMT

    [ https://issues.apache.org/jira/browse/HBASE-18182?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=16040615#comment-16040615
] 

Hadoop QA commented on HBASE-18182:
-----------------------------------

| (/) *{color:green}+1 overall{color}* |
\\
\\
|| Vote || Subsystem || Runtime || Comment ||
| {color:blue}0{color} | {color:blue} reexec {color} | {color:blue} 0m 31s {color} | {color:blue}
Docker mode activated. {color} |
| {color:blue}0{color} | {color:blue} shelldocs {color} | {color:blue} 0m 10s {color} | {color:blue}
Shelldocs was not available. {color} |
| {color:green}+1{color} | {color:green} @author {color} | {color:green} 0m 0s {color} | {color:green}
The patch does not contain any @author tags. {color} |
| {color:green}+1{color} | {color:green} shellcheck {color} | {color:green} 0m 7s {color}
| {color:green} There were no new shellcheck issues. {color} |
| {color:green}+1{color} | {color:green} whitespace {color} | {color:green} 0m 0s {color}
| {color:green} The patch has no whitespace issues. {color} |
| {color:green}+1{color} | {color:green} hadoopcheck {color} | {color:green} 64m 1s {color}
| {color:green} Patch does not cause any errors with Hadoop 2.6.1 2.6.2 2.6.3 2.6.4 2.6.5
2.7.1 2.7.2 2.7.3 or 3.0.0-alpha2. {color} |
| {color:green}+1{color} | {color:green} asflicense {color} | {color:green} 0m 25s {color}
| {color:green} The patch does not generate ASF License warnings. {color} |
| {color:black}{color} | {color:black} {color} | {color:black} 65m 24s {color} | {color:black}
{color} |
\\
\\
|| Subsystem || Report/Notes ||
| Docker | Client=17.03.0-ce Server=17.03.0-ce Image:yetus/hbase:757bf37 |
| JIRA Patch URL | https://issues.apache.org/jira/secure/attachment/12871795/HBASE-18182.0.patch
|
| JIRA Issue | HBASE-18182 |
| Optional Tests |  asflicense  shellcheck  shelldocs  |
| uname | Linux 3544851c117f 4.8.3-std-1 #1 SMP Fri Oct 21 11:15:43 UTC 2016 x86_64 x86_64
x86_64 GNU/Linux |
| Build tool | maven |
| Personality | /home/jenkins/jenkins-slave/workspace/PreCommit-HBASE-Build/component/dev-support/hbase-personality.sh
|
| git revision | master / 1d3252e |
| shellcheck | v0.4.6 |
| modules | C: . U: . |
| Console output | https://builds.apache.org/job/PreCommit-HBASE-Build/7127/console |
| Powered by | Apache Yetus 0.3.0   http://yetus.apache.org |


This message was automatically generated.



> Setting HBASE_REGIONSERVER_OPTS with UseG1GC will cause regionserver start error
> --------------------------------------------------------------------------------
>
>                 Key: HBASE-18182
>                 URL: https://issues.apache.org/jira/browse/HBASE-18182
>             Project: HBase
>          Issue Type: Bug
>          Components: regionserver
>    Affects Versions: 2.0.0, 1.1.6, 1.3.1, 1.2.6
>            Reporter: Fangyuan Deng
>             Fix For: 2.1.0, 1.3.2, 1.2.7
>
>         Attachments: HBASE-18182.0.patch
>
>
> when we set in hbase-env.sh to use G1GC HBASE_REGIONSERVER_OPTS="$HBASE_REGIONSERVER_OPTS
-XX:+UseG1GC -Xms96g -Xmx96g -XX:MaxGCPauseMillis=100"
> then run ./hbase-daemon.sh start regionserver
> Conflicting collector combinations in option list; please refer to the release notes
for the combinations allowed
> Error: Could not create the Java Virtual Machine.
> Error: A fatal exception has occurred. Program will exit.
> because the HBASE_OPTS default use CMS and is conflicted with HBASE_REGIONSERVER_OPTS
> so I add a patch to modify bin/hbase like this
> elif [ "$COMMAND" = "regionserver" ] ; then
>   CLASS='org.apache.hadoop.hbase.regionserver.HRegionServer'
>   if [ "$1" != "stop" ] ; then
>     HBASE_OPTS="$HBASE_OPTS $HBASE_REGIONSERVER_OPTS"
>     if [[ $HBASE_REGIONSERVER_OPTS == *UseG1GC*  ]] ; then
>       HBASE_OPTS=${HBASE_OPTS/'-XX:+UseConcMarkSweepGC'/''}
>     fi
>   fi



--
This message was sent by Atlassian JIRA
(v6.3.15#6346)

Mime
View raw message