hbase-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Qilin Cao (JIRA)" <j...@apache.org>
Subject [jira] [Comment Edited] (HBASE-18119) Improve HFile readability and modify ChecksumUtil log level
Date Wed, 21 Jun 2017 01:46:01 GMT

    [ https://issues.apache.org/jira/browse/HBASE-18119?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=16056786#comment-16056786
] 

Qilin Cao edited comment on HBASE-18119 at 6/21/17 1:45 AM:
------------------------------------------------------------

Hi, [~zyork],I think my original  test code(modify key/value then expect exception) was wrong,
for the configuration is only created once, if  the test case runs successfully, the modified
key/value may affect the class other tests.


was (Author: qilin cao):
Hi, [~zyork],I think my original  test code(modify key/value then expect exception) was wrong,
for the configuration is only created once, if I modify the configuration key/value successfully,
this may affect the class other tests.

> Improve HFile readability and modify ChecksumUtil log level
> -----------------------------------------------------------
>
>                 Key: HBASE-18119
>                 URL: https://issues.apache.org/jira/browse/HBASE-18119
>             Project: HBase
>          Issue Type: Improvement
>    Affects Versions: 2.0.0
>            Reporter: Qilin Cao
>            Assignee: Qilin Cao
>            Priority: Minor
>         Attachments: HBASE-18119-v1.patch, HBASE-18119-v2.patch, HBASE-18119-v3.patch,
HBASE-18119-v4.patch
>
>
> It is confused when I read the HFile.checkHFileVersion method, so I change the if expression.
Simultaneously, I change ChecksumUtil the info log level to trace.



--
This message was sent by Atlassian JIRA
(v6.4.14#64029)

Mime
View raw message