hbase-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Chia-Ping Tsai (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (HBASE-18008) Any HColumnDescriptor we give out should be immutable
Date Mon, 05 Jun 2017 16:26:04 GMT

    [ https://issues.apache.org/jira/browse/HBASE-18008?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=16037166#comment-16037166
] 

Chia-Ping Tsai commented on HBASE-18008:
----------------------------------------

bq. @Deprecated // remote it in 3.0 typo remote -> remove
copy that.

bq. Why did public byte[] getValue(byte[] key) move to the bottom of the file?
It is a mistaken change. Will undo it.

bq. Why rename a bunch of the methods?
# change "family" -> "ColumnFamily"
# We have the following codes across the code base of TableDescriptorBuilder. They have similar
implementation so I waited an new method getOrDefault() to replace them. The main aim is to
cleanup the redundant code.
  a)
    byte[] val = getValue(key);
    if (val == null || val.length == 0) {
      return defaultVal;
    }
  b) isSomething
  c) getIntValue

Thanks for your reviews.

> Any HColumnDescriptor we give out should be immutable
> -----------------------------------------------------
>
>                 Key: HBASE-18008
>                 URL: https://issues.apache.org/jira/browse/HBASE-18008
>             Project: HBase
>          Issue Type: Sub-task
>    Affects Versions: 2.0.0
>            Reporter: Chia-Ping Tsai
>            Assignee: Chia-Ping Tsai
>             Fix For: 2.0.0
>
>         Attachments: HBASE-18008.v0.patch, HBASE-18008.v1.patch, HBASE-18008.v2.patch,
HBASE-18008.v3.patch, HBASE-18008.v4.patch
>
>
> This is similar to HBASE-15583, but we should move up on to the ColumnFamilyDescriptor
rather than ColumnDescriptor.
>  



--
This message was sent by Atlassian JIRA
(v6.3.15#6346)

Mime
View raw message